Bug 885312 - RFE: Add extra jsmath fonts
RFE: Add extra jsmath fonts
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: jsmath-fonts (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-08 09:39 EST by Paulo Andrade
Modified: 2013-01-16 11:52 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-16 10:23:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paulo Andrade 2012-12-08 09:39:03 EST
Same issue as in missing stix reported in #885307 but in
this case the fonts are not in the source rpm.

Link to download directory is
http://www.math.union.edu/~dpvc/jsmath/download/extra-fonts/

And reason is some missing fonts, that are required by
python-matplotlib:

$ egrep -i "'cm" /usr/lib64/python2.7/site-packages/matplotlib/mathtext.py
        if cached_font.font.postscript_name == 'Cmex10':
    _fontmap = { 'cal' : 'cmsy10',
                 'rm'  : 'cmr10',
                 'tt'  : 'cmtt10',
                 'it'  : 'cmmi10',
                 'bf'  : 'cmb10',
                 'sf'  : 'cmss10',
                 'ex'  : 'cmex10'
        prop = FontProperties('cmex10')
        'cm'       : BakomaFonts,
                    "mathtext.fontset must be either 'cm', 'stix', "

and cause some failures, for example in my sagemath package:

    doctest:1214: UserWarning: findfont: Font family ['cmb10'] not found. Falling back to Bitstream Vera Sans
    doctest:1214: UserWarning: findfont: Font family ['cmtt10'] not found. Falling back to Bitstream Vera Sans
    doctest:1214: UserWarning: findfont: Font family ['cmss10'] not found. Falling back to Bitstream Vera Sans

I believe these fonts could be added in a jsmath-fonts-extras
but I believe python-maptlotlib could also be patched to not
require those (and the extra stix-fonts").
Comment 1 Paulo Andrade 2013-01-16 10:23:22 EST
I think I found an workaround that will cause it to not require
fonts not in the common js-math linux fonts tarball.
Since the stix-fonts bug report was closed as NOTABUG, this one
should also be so, as it is a smaller problem, and the workaround
should no longer trigger the warning messages.
Comment 2 Rex Dieter 2013-01-16 10:55:08 EST
Sorry for not replying yet, been a bit busy. :-/

Fwiw, I'm open to adding those (to an -extras subpkg perhaps) if there is still any remote need for these.
Comment 3 Fedora Update System 2013-01-16 11:46:14 EST
python-matplotlib-1.2.0-7.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-matplotlib-1.2.0-7.fc18
Comment 4 Paulo Andrade 2013-01-16 11:52:10 EST
(In reply to comment #2)
> Sorry for not replying yet, been a bit busy. :-/
> 
> Fwiw, I'm open to adding those (to an -extras subpkg perhaps) if there is
> still any remote need for these.

They should no longer be required. Well, they "could" be used if
available, but now it no longer generates any warning. I am also
hoping to find some time to split more the python-matplotlib
package, and add missing packages required to make extra backends
functional, as well as test the ones that have all requires already
in fedora and add they to requires and build requires as applicable.

Note You need to log in before you can comment on or make changes to this bug.