Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 885406 - enable qemu-ga service by default
Summary: enable qemu-ga service by default
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1165176 (view as bug list)
Depends On:
Blocks: 1160930
TreeView+ depends on / blocked
 
Reported: 2012-12-09 03:59 UTC by Cole Robinson
Modified: 2015-08-07 11:52 UTC (History)
11 users (show)

Fixed In Version: systemd-197-1.fc18.2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-15 10:35:27 UTC
Type: Bug


Attachments (Terms of Use)

Description Cole Robinson 2012-12-09 03:59:13 UTC
Similar to the spice-vdagent (bug 876237), please enable the qemu-ga service by default. The package installs udev rules that should cause it to only be enabled when actually inside a VM with a proper virtio-serial setup.

Comment 1 Lennart Poettering 2013-01-13 19:15:21 UTC
What's the precise systemd service name we shall add?

Comment 2 Cole Robinson 2013-01-14 14:23:03 UTC
$ cat /usr/lib/systemd/system/qemu-guest-agent.service
[Unit]
Description=QEMU Guest Agent
BindTo=dev-virtio\x2dports-org.qemu.guest_agent.0.device
After=dev-virtio\x2dports-org.qemu.guest_agent.0.device

[Service]
ExecStart=-/usr/bin/qemu-ga
Restart=always
RestartSec=0

[Install]

Comment 3 Lennart Poettering 2013-01-14 17:57:33 UTC
Commited this to the pkg git, didn't build this in koji though, but will be part of the next round of uploads.

Comment 4 Michal Schmidt 2013-01-18 14:14:58 UTC
Built in Rawhide (systemd-197-2.fc19), but not yet in F18.

Comment 5 Michal Schmidt 2013-03-15 10:35:27 UTC
I believe this is already fixed in systemd-197-1.fc18.2, I just forgot to link to this bug from the Bodhi update.

Comment 6 Jan Blazek 2015-08-07 11:52:46 UTC
*** Bug 1165176 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.