Bug 885464 - qemu 1.3.0 error: unsupported configuration: hda-duplex not supported in this QEMU binary
qemu 1.3.0 error: unsupported configuration: hda-duplex not supported in this...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
17
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-09 11:08 EST by John L Magee
Modified: 2013-01-09 07:12 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-09 11:51:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John L Magee 2012-12-09 11:08:41 EST
Description of problem: VM fails to start

Version-Release number of selected component (if applicable):  virsh version
Compiled against library: libvirt 1.0.0
Using library: libvirt 1.0.0
Using API: QEMU 1.0.0
Running hypervisor: QEMU 1.3.0

How reproducible: always

Steps to Reproduce:
1. attempt to start VM with sound model ICH6
2. observe error "error: unsupported configuration: hda-duplex not supported in this QEMU binary"
3.
  
Actual results: VM fails to start

Expected results: VM starts

Additional info: also fails with codec 'micro'

Note that Windows 7 does not support any of the other sound devices natively, if at all. So this will prevent the use of sound on Windows 7 guests until it is resolved
Comment 1 Cole Robinson 2012-12-09 11:51:42 EST
I assume you are using the virt-preview repo?

I accidentally pushed qemu 1.3 to virt-preview even though it is known not to work with libvirt 1.0.0. I'm fixing that now, please do a 'yum downgrade qemu' and restart libvirt.

More info:
https://lists.fedoraproject.org/pipermail/virt/2012-December/003503.html
Comment 2 Cole Robinson 2012-12-09 11:52:05 EST
That command should be:

yum downgrade qemu\*
Comment 3 John L Magee 2012-12-09 12:24:16 EST
downgrade worked fine and, of course, resolved the issue.

FWIW, my XP VM worked fine and so did the WIN7 VM when I changed the sound device. And, the issue with qemu crashing after spice disconnect when using es1370 sound device appeared to be resolved when I did a quick test.

Thanks much for the quick response.

Note You need to log in before you can comment on or make changes to this bug.