Bug 8855 - Can not create Multiple Software Raid Arrays
Summary: Can not create Multiple Software Raid Arrays
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 6.2
Hardware: alpha Linux
medium
medium
Target Milestone: ---
Assignee: Brock Organ
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-25 17:22 UTC by Richard D. Payne
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-17 14:08:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Richard D. Payne 2000-01-25 17:22:17 UTC
> > I'm having trouble with 6.2 beta and Raid Arrays. If I create 1 array
> > across the three drives it seems to be fine, if I try and make 2 then
the
> > installer hangs just before installing packages. No errors are reported
at
> > the GUI. However a CTRL-ALT-F1 shows:
> >
> > Exception in thread Tread-3:
> > Traceback (innermost last):
> > File "/usr/lib/python1.5/threading.py", line 376, in __bootstrap
> >     self.run()
> > File "/usr/lib/anaconda/iw/progress.py", line 16, in run
> >     rc = self.todo.doInstall()
> > File "/usr/lib/anaconda/todo.py", line 1229, in doInstall
> >     self.fstab.savePartitions ()
> > File "/usr/lib/anaconda/fstab.py", line 126, in SavePartitions
> >     self.ddruid.save()
> > SystemError: Error partitioing drive /tmp/sda: Device or resource busy
> >
> >
> > Now if we don't support multiple RAID arrays accros the same drives
that's
> > fine (I guess), but I think it needs tobe handled a little more
> > gracefully.

Comment 1 Brock Organ 2000-06-13 18:14:05 UTC
does this still occur using 6.2?

Comment 2 Brock Organ 2000-06-20 02:06:28 UTC
my apologies ... I didn't read closely to see that it was indeed a 6.2 problem
... :-(

Comment 3 Brock Organ 2000-07-13 21:38:48 UTC
hmmm  ... using 6.2 w/an adaptec 7899 controller here in our test lab, I am able
to create 2 raid arrays of 3 partitions (each partition within an array is on a
different drive) ... 

what scsi controller/machine hardware are you using ... ?


Comment 4 Richard D. Payne 2000-07-13 22:06:53 UTC
It was an adaptec 2940UW (don't have the card here and I don't remember the
chipset), and
3 Seagate disks. This was on a PC164LX.

FWIW, this was logged against a beta version of 6.2, not the final.

Comment 5 Brock Organ 2000-07-17 14:08:08 UTC
ok, it looks like the probelm was resolved between the 6.2 beta and 6.2 ...
please reopen if you still have any troubles ... thanks for your report!


Note You need to log in before you can comment on or make changes to this bug.