Bug 885524 - "tsc: Marking TSC unstable due to check_tsc_sync_source failed"
Summary: "tsc: Marking TSC unstable due to check_tsc_sync_source failed"
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 17
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 885523 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-10 00:18 UTC by entropy
Modified: 2013-10-04 00:17 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-10 14:53:02 UTC


Attachments (Terms of Use)
dmesg (54.20 KB, text/plain)
2013-01-10 00:49 UTC, entropy
no flags Details

Description entropy 2012-12-10 00:18:34 UTC
Description of problem:
dmesg always shows "tsc: Marking TSC unstable due to check_tsc_sync_source failed"


Version-Release number of selected component (if applicable):
kernel 3.6.8-2

How reproducible:
dmesg | grep failed

Steps to Reproduce:
unknown kernel failure message
  
Actual results:
uncritical annoying error

Expected results:
the error not to show up

Additional info: uname -r 
3.6.8-2.fc17.x86_64

Comment 1 Bill Nottingham 2012-12-10 16:27:33 UTC
*** Bug 885523 has been marked as a duplicate of this bug. ***

Comment 2 Josh Boyer 2013-01-07 20:54:37 UTC
There should be some other messages around that.  Could you please attach a full dmesg from boot?

Comment 3 entropy 2013-01-10 00:49:29 UTC
Created attachment 675949 [details]
dmesg

Comment 4 entropy 2013-01-10 00:49:54 UTC
Please see it above. Thanks.

Comment 5 Josh Boyer 2013-01-10 14:53:02 UTC
TSCs are kind of notorious for going out of sync between CPUs.  This is just saying the kernel isn't going to use the TSC.  Later in the boot, it switches the clocksource to hpet, so things should be fine.  There's really nothing to fix here.

Comment 6 Red Hat Bugzilla 2013-10-04 00:17:19 UTC
Removing external tracker bug with the id 'A124' as it is not valid for this tracker


Note You need to log in before you can comment on or make changes to this bug.