Bug 88557 - Intel PRO/1000 Fibre connection not working at AS 2.1
Summary: Intel PRO/1000 Fibre connection not working at AS 2.1
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 2.1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Larry Woodman
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-10 21:17 UTC by glshank
Modified: 2007-11-30 22:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-14 16:25:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description glshank 2003-04-10 21:17:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2) Gecko/20030208
Netscape/7.02

Description of problem:
After upgrading to AS 2.1 from RH 7.1, my Intel GB NIC is no longer working. It
is properly configured and up:

# ifconfig eth1
eth1      Link encap:Ethernet  HWaddr 00:03:47:4E:31:DE  
          inet addr:10.0.5.2  Bcast:10.0.5.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:23 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          RX bytes:0 (0.0 b)  TX bytes:1472 (1.4 Kb)
          Interrupt:19 Memory:f9ae0000-f9b00000

But trying to ping the host at the other end of the fibre cable returns:

# ping 10.0.5.1
PING 10.0.5.1 (10.0.5.1) from 10.0.5.2 : 56(84) bytes of data.
From 10.0.5.2: Destination Host Unreachable

I've tried the stock e1000.o driver and the e1000_4412k1.o driver to no avail.


Version-Release number of selected component (if applicable):
kernel-smp-2.4.9-e.16

How reproducible:
Always

Steps to Reproduce:
1.Install Intel PRO/1000 GB NIC (FIBRE, not twisted pair)
2.Connect a cross-over fibre cable to a GB NIC on another host
3.Configure NIC and try to ping other host
    

Actual Results:  # ping 10.0.5.1
PING 10.0.5.1 (10.0.5.1) from 10.0.5.2 : 56(84) bytes of data.
From 10.0.5.2: Destination Host Unreachable

Expected Results:  # ping 10.0.5.1
PING 10.0.5.1 (10.0.5.1) from 10.0.5.2 : 56(84) bytes of data.
64 bytes from 10.0.5.2: icmp_seq=0 ttl=255 time=28 usec
64 bytes from 10.0.5.2: icmp_seq=1 ttl=255 time=13 usec


Additional info:

This is a DELL Poweredge server running all the latest errata from rhn.

Comment 1 Chris Kloiber 2003-04-24 16:22:36 UTC
I was working with the customer on the support line.

PCI:ID is 8086:1001 (rev 2)

Either the card does not contain an inernal xcvr, or the driver/hardware is
ignoring ethtool requests to use the internal xcvr.

We have tried the 2.4.9-e.18smp QU2 beta errata kernel with the e1000 (version
5.0.43-k1) driver and the problem still occurs. The card worked fine under Red
Hat 7.1 using kernel 2.4.9-31.

Comment 2 glshank 2003-04-28 15:04:14 UTC
Just for grins, we rebooted the box at the other end of this fibre cable. It is
working now. I apologize for wasting your time with this apparent red herring.

Greg

Comment 3 Chris Kloiber 2003-06-14 16:25:01 UTC
Thanks for letting us know.


Note You need to log in before you can comment on or make changes to this bug.