Bug 885574 - Disabled iscsid by default on RHS2.0
Disabled iscsid by default on RHS2.0
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: build (Show other bugs)
2.0
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Bala.FA
Sachidananda Urs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-10 01:26 EST by Jin Zhou
Modified: 2015-11-22 21:57 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-10 03:43:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sac: needinfo+


Attachments (Terms of Use)

  None (edit)
Description Jin Zhou 2012-12-10 01:26:57 EST
Description of problem:

iscsid service is currently started by default. Please consider disable it or remove it from the default installation. Because RHS2.0 does not support the use of iscsi targets.

Thanks
Comment 2 Bala.FA 2012-12-11 01:02:01 EST
Fix for the patch is sent to aj and assigning him to examine the patch.
Comment 3 Anthony Towns 2013-01-16 06:16:34 EST
Change included in RHS-2.0-20130115.0 iso
Comment 4 Gowrishankar Rajaiyan 2013-01-16 06:33:57 EST
Default installation still has iscsid service as running.

[root@localhost ~]# /etc/init.d/iscsid status
iscsid (pid  1777) is running...
[root@localhost ~]# 

Tested RHS-2.0-20130115.0-RHS-x86_64-DVD1.iso
Comment 7 Bala.FA 2013-03-11 08:42:23 EDT
Please try RHS-2.0-20130219.3-RHS-x86_64-DVD1.iso which works for me.
Comment 8 Sachidananda Urs 2013-03-12 01:32:03 EDT
Tried with RHS-2.0-20130219.3-RHS-x86_64 I can still see iscsid running. I see that they are `on' on runlevelels 3,4,5
Comment 9 Bala.FA 2013-03-12 01:56:22 EDT
Have you used ISO with default installation method? How did you install it? kickstart/beaker/others?
Comment 10 Sachidananda Urs 2013-03-12 02:03:08 EDT
Yes, installed with default installation method. Tested by installing via beaker and via PXE. When installing with PXE it is next->next->next->install. No custom options are selected, so it is pretty much default.

I have a doubt, since I use the same ISO how does the installation method make it any different?
Comment 11 Sachidananda Urs 2013-03-12 02:42:29 EDT
[root@van ~]# chkconfig iscsid --list
iscsid          0:off   1:off   2:off   3:on    4:on    5:on    6:off
[root@van ~]#
Comment 12 Bala.FA 2013-03-12 02:54:29 EDT
(In reply to comment #10)
> Yes, installed with default installation method. Tested by installing via
> beaker and via PXE. When installing with PXE it is
> next->next->next->install. No custom options are selected, so it is pretty
> much default.
> 

As this bug is fixed in kickstart file which is used in ISO installation, I would like to check your kickstart file used in pxe.  You suppose to have something similar post

%post
sed -i -e 's/\(^SELINUX=\).*$/\1disabled/' /etc/selinux/config

# bz 885574
chkconfig iscsid off

# bz 920103
chkconfig tuned on

%end
Comment 13 Sachidananda Urs 2013-03-12 03:36:53 EDT
Tested by provisioning in the beaker and the ks file in the ISO. Works fine, can close.

[root@van ~]# service iscsid status
iscsid is stopped
[root@van ~]# chkconfig iscsid --list
iscsid          0:off   1:off   2:off   3:off   4:off   5:off   6:off
[root@van ~]# 


[root@dj tmp]# tail ks.cfg 
%post
sed -i -e 's/\(^SELINUX=\).*$/\1disabled/' /etc/selinux/config

# bz 885574
chkconfig iscsid off

# bz 920103
chkconfig tuned on

%end
[root@dj tmp]#

Note You need to log in before you can comment on or make changes to this bug.