Bug 88558 - Grub shipped with RH 9 0-93-4 does not work with high cylinder /boot
Grub shipped with RH 9 0-93-4 does not work with high cylinder /boot
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: grub (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-10 17:28 EDT by Robert H. Bliss
Modified: 2007-04-18 12:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 14:16:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert H. Bliss 2003-04-10 17:28:23 EDT
Description of problem:

I loaded 9 clean and grub would not boot the system. I normally load
RH linux into a high cylinder / partition and have had no problem doing
this on any of my systems. I removed grub-0.93-4 and installed the
version that came with 8.0 ie grub-0.92-7 and everything works fine.

I have not had the time yet to try this on a low cylinder /boot so
i am assuming that it is a high cylinder problem for now.

I tried this on two systems - a tyan/amd based system and a dual intel
P3 system with the same results.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
Comment 1 Devin 2003-04-13 09:38:26 EDT
I have the same problem, but with a strange twist.

After upgrading to RH 9 from RH 7.3, I noticed that before grub was loaded, my
BIOS was misreporting my hard drive size (I have a 20 GB hard drive, and my BIOS
was reporting it as a 1057 MB hard drive), and grub would boot to a prompt
instead of showing the RH graphic.

I figured that I would simply reset the parameters of the hard drive in my BIOS.
 So, I used the hard drive auto-detection mechanism in my BIOS, which found the
hard drive with the correct parameters.  I saved the configuration, rebooted the
computer, and ... same thing!  Right before grub loads, the hard drive size is
misreported!  I figured it might be a system BIOS caching problem, but I have
system BIOS caching disabled.

This problem didn't occur before upgrading to RH 9.

Help?
Comment 2 Robert H. Bliss 2003-04-13 17:25:55 EDT
I tried a 8.0 to 9 upgrade on a system that has a /boot partition at a low
cyclinder and 9.0 grub worked fine. Also as per Devin my first clean 9 load
also booted to a grub prompt which led me to the opinion that the new grub
could not access the graphic files in the high cylinder /boot. I also tried
a grub-install /dev/hda after booting from floppy. After doing that I did not
get a grub prompt but instead got a error message I think it was error 17 but
dummy me I did not write it down at the time.
Comment 3 Joe Smith 2003-04-18 23:43:18 EDT
> ... instead got a error message I think it was error 17 but
> dummy me I did not write it down at the time.

Yep, it's 17.  I just got bit as well - exact same behavior.  Downgrading to the
RH8 GRUB 0.92 fixed the problem.

I did notice that from the GRUB prompt, if I typed 'root (hd0,1)' I got a
message saying '... cylinder exceeds maximum supported by BIOS'.  But it seems
that the BIOS does handle it just fine.
Comment 4 Date J. Noorlag 2003-04-20 19:21:42 EDT
The following may be related to this problem.

One of my RH9 systems has four drives, a Maxtor 8Gb, two Maxtor 40Gb and a
Western Digital 120Gb. The geometry command of Grub 0.93-4 misreports the number
of cylinders of the 120Gb (35973cyl; BIOS (correctly) reports 232581cyl). The
other drives are correctly reported. The 120Gb drives has RH9, the other drives
are NT.

Before upgrading from RH8 to RH9, I used to boot Grub from Windows NT. After
upgrading this no longer worked. Grub reported "Geom Error" and hung. My
resolution was to change my boot sequence: Grub now gets booted first and the NT
bootloader is chain loaded from Grub.

I don't know whether Grub 0.92 misreports the 120Gb as well since I never used
the Grub geometry command before my recent upgrade.
Comment 5 Devin 2003-04-28 18:29:45 EDT
> ------ Additional Comment #4 From Date J. Noorlag on 2003-04-20 19:21------
> 
> The following may be related to this problem.
> 
> One of my RH9 systems has four drives, a Maxtor 8Gb, two Maxtor 40Gb and a
> Western Digital 120Gb. The geometry command of Grub 0.93-4 misreports the
> number of cylinders of the 120Gb (35973cyl; BIOS (correctly) reports
> 232581cyl).
> --snip--

Maybe I'm being unhelpful, but ...

This looks like an overflow error.  It looks like 2 bytes were used to hold the
number of cylinders instead of 4 bytes:

232581 modulus 65536 = 35973

This doesn't fix the problem, but hopefully it will help out the person trying
to fix the bug.
Comment 6 Jeremy Katz 2003-05-16 17:24:47 EDT
Does it work if you do '/sbin/grub-install --force-lba /dev/hda'
Comment 7 Robert H. Bliss 2003-05-21 10:22:30 EDT
No --force-lba did not fix my orriginal problem but did change the
the results - after the initial load on 9.0 the machine boots to
a grub command line prompt. after booting the machine from a floppy
and doing a '/sbin/grub-install --force-lba /dev/hda' grub gives the following

"GRUB Loading stage1.5

GRUB Loading, please wait....
Error 17
"
Comment 8 Peter Jones 2005-04-19 13:52:20 EDT
Is this still a problem in current Fedora Core test releases?
Comment 9 Bill Nottingham 2006-10-18 14:16:43 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
If this issue is still present in a current Fedora Core release, please
open a new bug with the relevant information.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.