This service will be undergoing disruptive maintenance at 7:00PM UTC, 2020-01-18. It is expected to last approximately one hour.
Bug 885590 - w3mhelp-funcdesc.ja.pl contains broken Japanese
Summary: w3mhelp-funcdesc.ja.pl contains broken Japanese
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: w3m
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Parag Nemade
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-10 07:21 UTC by Akira TAGOH
Modified: 2013-01-23 16:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-23 16:27:41 UTC


Attachments (Terms of Use)
screenshot (84.82 KB, image/png)
2012-12-11 08:53 UTC, Akira TAGOH
no flags Details

Description Akira TAGOH 2012-12-10 07:21:01 UTC
Description of problem:
%buf_funcdesc, %lineedit_funcdesc, %menu_funcdesc, and %title in /usr/share/w3m/w3mhelp-funcdesc.ja.pl contains broken Japanese.

Version-Release number of selected component (if applicable):
w3m-0.5.3-4.fc17.x86_64

How reproducible:
always

Steps to Reproduce:
1.see or open it with gedit
2.
3.
  
Actual results:
strings in those variables are broken. gedit reports an error.

Expected results:
no errors on gedit say

Additional info:

Comment 1 Parag Nemade 2012-12-11 06:23:00 UTC
I don't see any error in gnome-terminal when I open that file in gedit

Comment 2 Akira TAGOH 2012-12-11 08:53:43 UTC
Created attachment 661307 [details]
screenshot

No, it's not the error for debugging purpose that can be sometimes seen on the stderr. it is the sort of notification to users that the file might be broken. see the attached screenshot.

Comment 3 Akira TAGOH 2012-12-11 09:03:54 UTC
Okay, had looked into it carefully. this is because scripts/w3mhelp-funcdesc.ja.pl.in is encoded as EUC-JP and added at the end of file without any encoding conversion once generated from doc-jp/README.funcs, which is converted into UTF-8 at %prep.

Comment 4 Fedora Update System 2013-01-13 11:32:22 UTC
w3m-0.5.3-10.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/w3m-0.5.3-10.fc18

Comment 5 Fedora Update System 2013-01-14 04:07:11 UTC
Package w3m-0.5.3-10.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing w3m-0.5.3-10.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-0750/w3m-0.5.3-10.fc18
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2013-01-23 16:27:42 UTC
w3m-0.5.3-10.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.