Bug 885609 - Changing hostname in gnome-shell creates /etc/hostname but does not change /etc/sysconfig/network
Changing hostname in gnome-shell creates /etc/hostname but does not change /e...
Status: CLOSED DUPLICATE of bug 881785
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-10 03:35 EST by Mildred
Modified: 2012-12-10 04:44 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-10 04:44:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mildred 2012-12-10 03:35:09 EST
Description of problem:
When changing hostname in gnome-shell system settings, the configuration file /etc/hostname gets created by (supposedly) systemd, but the system fails to update /etc/sysconfig/network. I don't know if this file is supposed to be updated (mine still contained localhost.localdomain) but on next reboot, the hostname was still not changed to the new one.


Version-Release number of selected component (if applicable): systemd-195-8.fc18.x86_64

How reproducible: always

Steps to Reproduce:
1. Install a fresh Fedora 18
2. Log in to gnome shell and choose system settings, and then details
3. change hostname to something else than localhost.localdomain
  
Actual results:
- On next reboot, the hostname has not been changed
- /etc/hostname contains the new hostname
- /etc/sysconfig/network contains localhost.localdomain

Expected results:
I don't know about /etc/sysconfig/network, but definitely, on next reboot, the hostname should have been updated.

Additional info: On a fresh install (not updated using FedUp)
Comment 1 Michal Schmidt 2012-12-10 04:44:17 EST
The HOSTNAME= setting in /etc/sysconfig/network will hopefully go away in F18, leaving /etc/hostname the only configuration file for setting the hostname.

*** This bug has been marked as a duplicate of bug 881785 ***

Note You need to log in before you can comment on or make changes to this bug.