Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 885624 - [RHS-C]: Services tab in Cluster is showing the details of the hosts from other Cluster
Summary: [RHS-C]: Services tab in Cluster is showing the details of the hosts from oth...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc
Version: 2.0
Hardware: All
OS: All
high
high
Target Milestone: ---
: ---
Assignee: Kanagaraj
QA Contact: Prasanth
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-10 09:09 UTC by Prasanth
Modified: 2016-04-18 10:05 UTC (History)
6 users (show)

Fixed In Version: qa4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-23 22:25:29 UTC
Target Upstream Version:


Attachments (Terms of Use)
cluster_with_no_hosts (108.86 KB, image/jpeg)
2012-12-10 09:09 UTC, Prasanth
no flags Details
status_of_empty_cluster (140.30 KB, image/jpeg)
2012-12-10 09:10 UTC, Prasanth
no flags Details

Description Prasanth 2012-12-10 09:09:58 UTC
Created attachment 660638 [details]
cluster_with_no_hosts

Description of problem:

Services tab in Cluster is showing the details of the hosts from other Cluster as well.

Version-Release number of selected component (if applicable): rhsc-2.1-qa18.el6ev.noarch


How reproducible: Always


Steps to Reproduce:
1. Create a Cluster with some hosts, say Cluster1
2. Create a Cluster with no hosts added, say Cluster2
3. Now select the empty Cluster (Cluster2) and click on the Services tab.
4. You will see the service details of the Hosts from Cluster1 in it.
  
Actual results: It is currently displaying the service details of the hosts that are not part of its cluster


Expected results: It shouldn't display the service details of the Hosts that are part of a different cluster


Additional info: Screenshots attached.

Comment 1 Prasanth 2012-12-10 09:10:40 UTC
Created attachment 660639 [details]
status_of_empty_cluster

Comment 3 Kanagaraj 2012-12-11 17:51:05 UTC
Patch sent to upstream: http://gerrit.ovirt.org/9858

Comment 4 Kanagaraj 2012-12-19 16:15:52 UTC
Patch merged in upstream.

Comment 5 Prasanth 2013-01-10 11:14:49 UTC
Verified in rhsc-2.1-0.qa4d.el6

Comment 6 Scott Haines 2013-09-23 22:25:29 UTC
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html


Note You need to log in before you can comment on or make changes to this bug.