Bug 885760 - Unable to query Virtualization information from getDetails
Unable to query Virtualization information from getDetails
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
550
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Tomas Lestach
Martin Korbel
: FutureFeature
Depends On:
Blocks: sat560-api
  Show dependency treegraph
 
Reported: 2012-12-10 10:02 EST by Ryan Hennessy
Modified: 2013-10-01 17:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:44:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ryan Hennessy 2012-12-10 10:02:17 EST
Description of problem:
When viewing a Virtual Machine in the Satellite interface, the details page will show a Virtualization field.  The field will provide information on which type of hypervisor the guest is running on.    When using the API the system.getDetails method does not contain that information.   

Version-Release number of selected component (if applicable):
This has been tested on 5.5

How reproducible:
Call the system.getDetails method in the API

Steps to Reproduce:
1.
2.
3.
  
Actual results:
No Value

Expected results:
Have a Virtualization value in the returned struct.

Additional info:
Comment 1 Tomas Lestach 2013-01-07 10:36:30 EST
Adding "virtualization" type for virtual guests to ServerSerializer ...

spacewalk.git: c62b47eccc7ef92a1fcc5e4f2f9abcfac32735d0
Comment 3 Martin Korbel 2013-05-27 09:32:24 EDT
VERIFIED on Satellite-5.6.0-RHEL6-re20130521.0
spacewalk-java-1.9.83-35.el6sat.noarch  

I haven't reproduced of this bug !!!

Steps:
1. register virtual guest into satellite
2. update variables and run this script

#!/usr/bin/python
import xmlrpclib

SATELLITE_URL = "http://localhost/rpc/api"
SATELLITE_LOGIN = "admin"
SATELLITE_PASSWORD = "xxx"
SID = 1000010004

client = xmlrpclib.Server(SATELLITE_URL, verbose=0)

key = client.auth.login(SATELLITE_LOGIN, SATELLITE_PASSWORD)
detail =  client.system.getDetails(key, SID)
print "Type of virtualization: %s" % detail.get('virtualization')

client.auth.logout(key)
Comment 5 Clifford Perry 2013-10-01 17:40:22 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.