Bug 885762 - texlive no longer provides /etc/rpm/macros.texlive
texlive no longer provides /etc/rpm/macros.texlive
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: texlive (Show other bugs)
18
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
: Regression
Depends On: 904700
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-10 10:07 EST by Rex Dieter
Modified: 2013-07-02 19:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-15 19:57:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2012-12-10 10:07:01 EST
Compared to prior texlive releases (like what's included in fedora 17), texlive packaging no longer seems to provide
/etc/rpm/macros.texlive

On fedora 17, /etc/rpm/macros.texlive contained:
# macros to keep trees in texlive consistent
%_texmf_main     /usr/share/texmf
%_texmf_vendor   /usr/share/texmf
%_texmf_var      /var/lib/texmf
%_texmf_conf     /etc/texmf

Was this on purpose or oversight/regression?

I ask because this change currently breaks pvs-sbcl builds...
Comment 1 Jens Petersen 2013-01-28 02:48:02 EST
And also ctan-cm-lgc-fonts and ctan-kerkis-fonts...
Comment 2 Jindrich Novy 2013-01-28 06:42:58 EST
Ok, I added the macros file in texlive-base package. I will build new texlive as soon as new harfbuzz is in buildroots.
Comment 3 Fedora Update System 2013-02-06 09:32:27 EST
texlive-2012-16.20130205_r29034.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/texlive-2012-16.20130205_r29034.fc18
Comment 4 Fedora Update System 2013-02-07 21:15:28 EST
Package texlive-2012-16.20130205_r29034.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing texlive-2012-16.20130205_r29034.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-2048/texlive-2012-16.20130205_r29034.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-02-15 19:57:34 EST
texlive-2012-16.20130205_r29034.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.