Bug 885767 - Organization switcher does not appear after initial login in headpin.
Organization switcher does not appear after initial login in headpin.
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Katello Bug Bin
sthirugn@redhat.com
: Reopened, TestBlocker
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2012-12-10 10:19 EST by Gerhard Stoeckel
Modified: 2013-10-01 06:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 06:54:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gerhard Stoeckel 2012-12-10 10:19:08 EST
Description of problem:
When attempting to log into headpin, the org switcher does not appear after submitting the username and password.  A success notification instructing the user to select and org is displayed after login, but there is no ability to select an organization.  However, if the page is refreshed, the home page is then displayed.

Version-Release number of selected component (if applicable):


How reproducible:
Very

Steps to Reproduce:
1. Navigate to headpin server in web browser.
2. Log in with ["admin" "admin"] 
3. Notice no org-switcher and no way to proceed.
  
Actual results:


Expected results:


Additional info:
This is obviously causing a ton of automation tests to fail.
Comment 1 Gerhard Stoeckel 2012-12-10 12:11:42 EST
Headpin Version: 1.3.0-1.git.27.d899940.el6_3
Comment 2 Og Maciel 2012-12-10 12:28:06 EST
Problem seems to happen when you have more than one organization created (but no favorite org).
Comment 3 Tom McKay 2012-12-18 09:43:29 EST
Fixed upstream
Comment 4 Og Maciel 2012-12-19 10:12:39 EST
Re-opening so QE can track it properly.
Comment 7 Bryan Kearney 2013-09-20 15:58:13 EDT
Given the dates, I am assuming this has been delivered.
Comment 10 sthirugn@redhat.com 2013-09-20 16:12:12 EDT
Verified in headpin and SAM.

SAM version tested:
* candlepin-0.8.26-1.el6sam.noarch
* candlepin-cert-consumer-cloud-qe-19.idm.lab.bos.redhat.com-1.0-1.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.26-1.el6sam.noarch
* candlepin-tomcat6-0.8.26-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-11.el6sat.noarch
* katello-cli-common-1.4.3-11.el6sat.noarch
* katello-common-1.4.3-15.el6sam_splice.noarch
* katello-configure-1.4.4-4.el6sat.noarch
* katello-glue-candlepin-1.4.3-15.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-15.el6sam_splice.noarch
* katello-headpin-1.4.3-15.el6sam_splice.noarch
* katello-headpin-all-1.4.3-15.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.34-1.el6sam.noarch
* thumbslug-selinux-0.0.34-1.el6sam.noarch


headpin version tested:
* candlepin-0.8.27-1.el6.noarch
* candlepin-cert-consumer-sun-x4600m2-01.rhts.eng.bos.redhat.com-1.0-1.noarch
* candlepin-selinux-0.8.27-1.el6.noarch
* candlepin-tomcat6-0.8.27-1.el6.noarch
* elasticsearch-0.19.9-7.el6.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.4-1.el6.noarch
* katello-cli-1.4.3-1.git.58.e7174b6.el6.noarch
* katello-cli-common-1.4.3-1.git.58.e7174b6.el6.noarch
* katello-common-1.4.6-1.git.229.a5bf625.el6.noarch
* katello-configure-1.4.5-1.git.10.4c7affb.el6.noarch
* katello-glue-candlepin-1.4.6-1.git.229.a5bf625.el6.noarch
* katello-glue-elasticsearch-1.4.6-1.git.229.a5bf625.el6.noarch
* katello-headpin-1.4.6-1.git.229.a5bf625.el6.noarch
* katello-headpin-all-1.4.6-1.git.229.a5bf625.el6.noarch
* Katello-Katello-Installation-RegisterRHNClassic-1.1-4.noarch
* Katello-Katello-Sanity-ImportKeys-1.2-1.noarch
* katello-repos-1.4.2-1.el6.noarch
* katello-selinux-1.4.4-1.git.1.7abb02b.el6.noarch
* thumbslug-0.0.27-1.el6.noarch
* thumbslug-selinux-0.0.27-1.el6.noarch
Comment 12 errata-xmlrpc 2013-10-01 06:54:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.