This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 885830 - modcluster{,d} crashes when local cluster.conf file is too large
modcluster{,d} crashes when local cluster.conf file is too large
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: clustermon (Show other bugs)
6.4
Unspecified Unspecified
medium Severity high
: rc
: ---
Assigned To: Jan Pokorný
Cluster QE
: EasyFix
Depends On: 877381
Blocks: 886216
  Show dependency treegraph
 
Reported: 2012-12-10 13:12 EST by Radek Steiger
Modified: 2013-02-21 05:56 EST (History)
5 users (show)

See Also:
Fixed In Version: clustermon-0.16.2-20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 877381
Environment:
Last Closed: 2013-02-21 05:56:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 2 Radek Steiger 2012-12-10 13:16:04 EST
I used a cluster.conf similar to that provided by Chris:
https://bugzilla.redhat.com/show_bug.cgi?id=815752#c5


With such config file modcluster crashed immediately upon start while parsing the local cluster.con.

GDB backtrace:

#0  File::read (this=0x7ffff7fe8280) at File.cpp:144
#1  0x00000000004231e9 in File::operator String const (this=<value optimized out>) at File.cpp:215
#2  0x0000000000438593 in readXML (filename=<value optimized out>) at XML.cpp:303
#3  0x000000000040e8b3 in ClusterMonitoring::Monitor::parse_cluster_conf (this=<value optimized out>) at Monitor.cpp:304
#4  0x000000000040fb93 in ClusterMonitoring::Monitor::get_local_info (this=0x7fffffffe280, nodename="", clustername="", msg="") at Monitor.cpp:199
#5  0x0000000000411aaf in ClusterMonitoring::Monitor::run (this=0x7fffffffe280) at Monitor.cpp:98
#6  0x000000000042cd7a in start_thread (thread_obj=<value optimized out>) at Thread.cpp:31
#7  0x000000324ca07851 in start_thread (arg=0x7ffff7fe9700) at pthread_create.c:301
#8  0x000000324c2e890d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115


# rpm -q modcluster
modcluster-0.16.2-19.el6.x86_64

Fix should probably be the same as in ricci (attachment 648116 [details]) in bug 877381.
Comment 5 Jan Pokorný 2012-12-10 13:45:16 EST
BTW., both modclusterd and modcluster (from the same modcluster subpackage)
are affected as they both link with the same culprit module.
Comment 10 errata-xmlrpc 2013-02-21 05:56:07 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0469.html

Note You need to log in before you can comment on or make changes to this bug.