Bug 8859 - postgresql cause random hard system crashes on Ultra5 and Ultra10
postgresql cause random hard system crashes on Ultra5 and Ultra10
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.1
sparc Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-25 12:36 EST by Steevithak
Modified: 2016-06-22 14:01 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-22 15:27:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steevithak 2000-01-25 12:36:18 EST
Using postgreSQL on RH61 on a Sun Ultra5 or Ultra10 (possibly other sparcs)
results in random hard crashes. These are major crashes - stop-A and the
reset switch don't work, the system must be powered down and restarted and
data loss on the hard disk can occur. A search on deja news reveals that
others are having the same results using other Linux distributions. It
seems to be a kernel related problem rather than a problem in postgreSQL
but I don't have the ability to debug it. At least one user who was having
crashes on a sun Ultra5 running Debian found that upgrading to the newest
kernel solved the problem. Running the regression test will usually cause
the crash, otherwise during normal use, the database causes the crash at
unpredictable intervals - in one case it ran for several days in another it
crashed hard two time in the same hour.
Comment 1 Trond Eivind Glomsrxd 2000-04-06 18:54:59 EDT
Nothing should crash the kernel, so I've reorganized it. Does this happen with
the 6.2 kernel, BTW?
Comment 2 Alan Cox 2000-08-08 15:11:50 EDT
Closed due to no reply
Comment 3 openshift-github-bot 2016-06-22 13:03:00 EDT
Commit pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/461ce39506a4c99d250affc5b120ee8e2e1c56b7
Unmarshal ports given in integer format

When docker-compose had a port number written in integer
format, while conversion, it was not being marshalled to
string format, added a type check which will do the int to
string conversion.

Fixes issue #8859
Comment 4 Steevithak 2016-06-22 14:01:39 EDT
Wow! Wasn't expecting to see an update email on a bug I filed 16 years ago on RedHat 6.1! lol Fwiw, I haven't run RH on a sparc for a decade or so. :)

Note You need to log in before you can comment on or make changes to this bug.