Bug 88591 - java causes segmentation fault
java causes segmentation fault
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-11 01:25 EDT by Volker Meyer
Modified: 2016-11-24 10:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-17 14:58:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Volker Meyer 2003-04-11 01:25:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.1)
Gecko/20020823 Netscape/7.0 (BDP)

Description of problem:
Command "java" in package IBMJava2-JRE-1.3.1-3.0.i386.rpm
causes segmentation fault.
The glibc in the original RH9 release worked.
The new glibc doesn't.


Version-Release number of selected component (if applicable):
glibc-2.3.2-27.9.i686

How reproducible:
Always

Steps to Reproduce:
1. java from package IBMJava2-JRE-1.3.1-3.0.i386.rpm
2.
3.
    

Actual Results:  segmentation fault

Expected Results:  Starting Java

Additional info:
Comment 1 Warren Togami 2003-04-13 02:46:10 EDT
If you read the release notes, you need to use minimally Java 1.4.1, but that to me has 
segfaulted quite often unless I use LD_ASSUME_KERNEL=2.2.5 to disable NPTL.   I'm now 
using Sun Java 1.4.2 beta and it seems to be stable without disabling NPTL. 
Comment 2 Volker Meyer 2003-04-14 01:58:44 EDT
I wish SAP would read the release notes. They still insist on users, wishing to
access SAP applicationservers via JAVA, to use 1.3.1.
According to SAP, Java1.4.x is not supported.
Try intalling a SAP-Gui with Java1.4. It won't work.
I am now using 1.3.1 from sun, and that doesn't segfault.
Comment 3 Ulrich Drepper 2003-04-17 14:58:36 EDT
I'm closing this bug since it is no problem in glibc.  Most Java implementations
are broken.  Sun's is the best (= most compliant wrt the glibc ABI)
implementation.  1.4.1 and 1.4.2 of Sun's JVM seem to work nicely.
Comment 4 Volker Meyer 2003-04-22 02:39:08 EDT
I opened a call at SAP with the number: 002007974700001463272003

It's probably not accessible by public, but if there's anybody else out there,
stupid enough to try using a Java SAP-GUI on Linux, you might want to coninue
reading this bug. =:)
Comment 5 Nils Philippsen 2003-05-21 08:24:18 EDT
Works for me when using LD_ASSUME_KERNEL=2.2.5; System is Red Hat Linux 9 with
all current updates (kernel-2.4.20-13.9, glibc-2.3.2-27.9), Java is IBM Java 1.3.1.

Cheers,
Nils, Red Hat @ SAP LinuxLab

Note You need to log in before you can comment on or make changes to this bug.