Bug 88593 - The RHL 9 syslinux is old and missing some minor components
The RHL 9 syslinux is old and missing some minor components
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: syslinux (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-11 02:42 EDT by H. Peter Anvin
Modified: 2007-04-18 12:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 16:30:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description H. Peter Anvin 2003-04-11 02:42:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030211

Description of problem:
The syslinux shipped with RHL 9 (Shrike) is a bit old (2.00, current one when
Shrike shipped was 2.02 and 2.03 is now out.)  2.03 fixes booting on especially
some PXE platforms.

Furthermore, it's missing some minor components.  What is somewhat more severe
is that the license is misstates as BSD in the RPM (it's actually GPL.)

I actually maintain official RPMS for syslinux these days; I have migrated most
of the relevant changes from the RedHat 2.00-4 RPM into the SYSLINUX 2.03-1 RPM.
 You may want to consider using that as a basis.


Version-Release number of selected component (if applicable):
syslinux-2.00-4

How reproducible:
Always

Steps to Reproduce:
N/A

Additional info:
Comment 1 Richard Black 2003-04-21 10:19:35 EDT
Fix in 2.00 that is needed:
#  PXELINUX: Fix bug where PXELINUX would override random chunks of the UNDI
code segment! Thanks to Kevin Tran for finding this bug.

In our case kernel and initrd would load but would not attempt to boot.
Comment 2 Jeremy Katz 2003-04-21 13:01:33 EDT
syslinux is something that I'm pretty cautious about updating after the first
public beta just because of it being one of those things that if it breaks,
there's nothing I can do about it after release (other than put out new boot
media).   2.04 built for rawhide integrating most of the changes in your package.
Comment 3 Bill Nottingham 2006-08-04 16:30:46 EDT
Red Hat Linux and Red Hat Powertools are currently no longer supported by Red
Hat, Inc. In an effort to clean up bugzilla, we are closing all bugs in MODIFIED
state for these products.

However, we do want to make sure that nothing important slips through the
cracks. If, in fact, these issues are not resolved in a current Fedora Core
Release (such as Fedora Core 5), please open a new issues stating so. Thanks.

Note You need to log in before you can comment on or make changes to this bug.