Bug 885934 - RFE: option to avoid encoding tab as \t
RFE: option to avoid encoding tab as \t
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-Maven (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity medium
: ---
: 2.1
Assigned To: Sean Flanigan
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-10 23:01 EST by Sean Flanigan
Modified: 2013-02-27 02:57 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.1-SNAPSHOT (20121214-0032)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-27 02:57:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sean Flanigan 2012-12-10 23:01:54 EST
Description of problem:

Publican doesn't like it when a PO file uses \t in msgids for a string which is a tab in the original DocBook XML.  We should add an option to avoid encoding tab as \t, and just use tab characters.  The default will still be to encode tabs, because this is how the Gettext tools behave (eg msgmerge, msgcat).

Version-Release number of selected component (if applicable):
2.0.2-SNAPSHOT

How reproducible:
100%

Steps to Reproduce:
1. Push a POT file containing tab characters into Zanata
2. Pull a PO file from Zanata
3. Observe the representation of the tab characters in the PO's msgid and msgstr fields.
  

Additional info:

The new option (in Maven's "pull" goal) will be -Dzanata.encodeTabs, which will default to true.  If the option -Dzanata.encodeTabs=false is provided, tabs should be as-is.
Comment 2 Ding-Yi Chen 2012-12-14 03:03:18 EST
VERIFIED with Zanata version 2.1-SNAPSHOT (20121214-0032)
[INFO] client API version: 2.0.0, server API version: 2.0.1

Note You need to log in before you can comment on or make changes to this bug.