Bug 885994 - [User Portal] Run Once - Boot Options should not list Hard Disk when the VM is diskless - consistency with PXE/network boot
[User Portal] Run Once - Boot Options should not list Hard Disk when the VM i...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-userportal (Show other bugs)
3.2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.2.0
Assigned To: Arik
Jiri Belka
virt
: Reopened
: 947849 (view as bug list)
Depends On:
Blocks: 915537 922807 948448
  Show dependency treegraph
 
Reported: 2012-12-11 04:30 EST by Jiri Belka
Modified: 2013-06-11 04:44 EDT (History)
10 users (show)

See Also:
Fixed In Version: sf10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 11735 None None None Never
oVirt gerrit 12454 None None None Never
oVirt gerrit 12769 None None None Never

  None (edit)
Description Jiri Belka 2012-12-11 04:30:17 EST
Description of problem:

In User Portal -> Run Once - Boot Options - when the VM has no network card 'Network (PXE)' is unavailable in 'Boot sequence', this is OK. While the VM is diskless 'Hard Disk' still can be selected/is available in 'Boot sequence' list. When selecting 'Hard Disk' for diskless VM an user sees logically/correctly error popup window but still there's inconsitency - networkless VM = no network/PXE available vs. diskless VM = booting from HD available.

Version-Release number of selected component (if applicable):

si25

How reproducible:
100%

Steps to Reproduce:
1. Create a new VM in User Portal without network and disk (default, just 'New Server')
2. Check Run Once -> Boot options
  
Actual results:

'Hard Disk' is present in 'Boot sequence' for diskless VM.

Expected results:

'Hard Disk' should be not available for diskless VM, same consitency for unavailable booting from network/PXE when a VM has no network interface.
Additional info:
Comment 2 Jiri Belka 2013-03-05 04:30:33 EST
Not fully OK - I created a diskless VM, in 'Run Once' dialog there's correctly 'Network (PXE)' in 'Boot Sequence' but when starting it in paused mode and later clicked 'Run' icon, I got:

diskless:

    Cannot run VM without at least one bootable disk.
    Alternatives:
    -Create a disk for this VM, and rerun the VM.
    -Change the boot sequence using the Edit VM command (Boot Option Sub-Tab).
    -Use the Run-Once command to select a different boot option and rerun the VM.

When starting directly (not via paused mode), it works OK.
Comment 4 Jiri Belka 2013-03-12 07:39:16 EDT
ok, sf10, now it works even in paused mode.
Comment 5 Roy Golan 2013-04-10 01:42:18 EDT
*** Bug 947849 has been marked as a duplicate of this bug. ***
Comment 6 Itamar Heim 2013-06-11 04:35:56 EDT
3.2 has been released
Comment 7 Itamar Heim 2013-06-11 04:35:59 EDT
3.2 has been released
Comment 8 Itamar Heim 2013-06-11 04:36:01 EDT
3.2 has been released
Comment 9 Itamar Heim 2013-06-11 04:44:36 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.