This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 88604 - gedit creates file backups that nautilus can't see!!!
gedit creates file backups that nautilus can't see!!!
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: gedit (Show other bugs)
9
athlon Linux
high Severity high
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-11 06:49 EDT by Philip Wyett
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-12 15:37:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip Wyett 2003-04-11 06:49:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
gedit in Red Hat 9 is creating backups in the form of:

filename~

Nautilus can see hidden and backup files in the following form:

.filename or ~filename

The only way to see the backups created by gedit at present is
in a terminal or another such component which shows directories
as is.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a file in gedit and save as test.txt
2. Modify the file and then save.
3. Now open nautilus. With or without the 'Show hidden and backup files'
   checkbox checked in the nautilus file managment preferences and
   the backup file created by gedit is not visible.
    

Actual Results:  Can't view the backup files created by gedit in nautilus.

Expected Results:  I expect to set to show hidden and backups files and be able
to see them all in nautilus.

Additional info:

I wil give this a high priority as it can have people unknowingly filling up
their disks with backup files they cannot see. Bad in anybody's book!
Comment 1 Philip Wyett 2003-04-12 15:23:04 EDT
A little investigation of backup creation shows the following...

Note: This was a quick look. :)

gedit(s) where this problem occurs
==================================

gedit-2.2.0/src/gedit-document.c (Version in RH 9)
gedit-2.2.1/src/gedit-document.c
gedit-2.3.0/gedit/gedit-document.c

where bad g_strconcat () occurs
===============================

Lines - 1316, 1317 and 1318

Is at present:

backup_filename = g_strconcat (real_filename, 
                               bak_ext,
                               NULL);

Should really be:

backup_filename = g_strconcat (bak_ext, 
                               real_filename,
                               NULL);
Comment 2 Havoc Pennington 2003-04-12 15:37:38 EDT
I don't think it's that nautilus can't see them, more that 
nautilus deliberately hides them. So really this is a nautilus issue.

We wouldn't change this in a Red Hat specific patch though.
I think the current behavior is "by design" but you might 
file it on bugzilla.gnome.org or ask on nautilus-list@gnome.org 
if you think it should be handled differently.

Note You need to log in before you can comment on or make changes to this bug.