Bug 886062 - [abrt] python-2.7.3-13.fc18: list_resize: Process /usr/bin/python2.7 was killed by signal 6 (SIGABRT)
Summary: [abrt] python-2.7.3-13.fc18: list_resize: Process /usr/bin/python2.7 was kill...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: python
Version: 18
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f498d269a5cd353180e1da459f4...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-11 12:37 UTC by Jan Teichmann
Modified: 2013-01-10 09:15 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-10 09:15:13 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (47.23 KB, text/plain)
2012-12-11 12:37 UTC, Jan Teichmann
no flags Details
File: build_ids (4.32 KB, text/plain)
2012-12-11 12:37 UTC, Jan Teichmann
no flags Details
File: cgroup (126 bytes, text/plain)
2012-12-11 12:37 UTC, Jan Teichmann
no flags Details
File: core_backtrace (7.49 KB, text/plain)
2012-12-11 12:37 UTC, Jan Teichmann
no flags Details
File: dso_list (10.46 KB, text/plain)
2012-12-11 12:37 UTC, Jan Teichmann
no flags Details
File: environ (3.00 KB, text/plain)
2012-12-11 12:38 UTC, Jan Teichmann
no flags Details
File: limits (1.29 KB, text/plain)
2012-12-11 12:38 UTC, Jan Teichmann
no flags Details
File: maps (48.81 KB, text/plain)
2012-12-11 12:38 UTC, Jan Teichmann
no flags Details
File: open_fds (3.68 KB, text/plain)
2012-12-11 12:38 UTC, Jan Teichmann
no flags Details
File: proc_pid_status (890 bytes, text/plain)
2012-12-11 12:38 UTC, Jan Teichmann
no flags Details
File: var_log_messages (471 bytes, text/plain)
2012-12-11 12:38 UTC, Jan Teichmann
no flags Details

Description Jan Teichmann 2012-12-11 12:37:45 UTC
Version-Release number of selected component:
python-2.7.3-13.fc18

Additional info:
backtrace_rating: 4
cmdline:        /usr/bin/python /usr/bin/yum update -x qemu*
crash_function: list_resize
executable:     /usr/bin/python2.7
kernel:         3.6.9-4.fc18.x86_64
remote_result:  NOTFOUND
uid:            0

Truncated backtrace:
Thread no. 1 (10 frames)
 #6 list_resize at /usr/src/debug/Python-2.7.3/Objects/listobject.c:62
 #7 app1 at /usr/src/debug/Python-2.7.3/Objects/listobject.c:286
 #8 pysqlite_connection_register_cursor at /usr/src/debug/Python-2.7.3/Modules/_sqlite/connection.c:310
 #9 pysqlite_cursor_init at /usr/src/debug/Python-2.7.3/Modules/_sqlite/cursor.c:118
 #10 type_call at /usr/src/debug/Python-2.7.3/Objects/typeobject.c:737
 #11 PyObject_Call at /usr/src/debug/Python-2.7.3/Objects/abstract.c:2529
 #12 call_function_tail at /usr/src/debug/Python-2.7.3/Objects/abstract.c:2561
 #13 PyObject_CallFunction at /usr/src/debug/Python-2.7.3/Objects/abstract.c:2585
 #14 pysqlite_connection_cursor at /usr/src/debug/Python-2.7.3/Modules/_sqlite/connection.c:341
 #15 call_function at /usr/src/debug/Python-2.7.3/Python/ceval.c:4098

Comment 1 Jan Teichmann 2012-12-11 12:37:49 UTC
Created attachment 661401 [details]
File: backtrace

Comment 2 Jan Teichmann 2012-12-11 12:37:51 UTC
Created attachment 661402 [details]
File: build_ids

Comment 3 Jan Teichmann 2012-12-11 12:37:53 UTC
Created attachment 661403 [details]
File: cgroup

Comment 4 Jan Teichmann 2012-12-11 12:37:55 UTC
Created attachment 661404 [details]
File: core_backtrace

Comment 5 Jan Teichmann 2012-12-11 12:37:58 UTC
Created attachment 661405 [details]
File: dso_list

Comment 6 Jan Teichmann 2012-12-11 12:38:01 UTC
Created attachment 661406 [details]
File: environ

Comment 7 Jan Teichmann 2012-12-11 12:38:03 UTC
Created attachment 661407 [details]
File: limits

Comment 8 Jan Teichmann 2012-12-11 12:38:05 UTC
Created attachment 661408 [details]
File: maps

Comment 9 Jan Teichmann 2012-12-11 12:38:07 UTC
Created attachment 661409 [details]
File: open_fds

Comment 10 Jan Teichmann 2012-12-11 12:38:09 UTC
Created attachment 661410 [details]
File: proc_pid_status

Comment 11 Jan Teichmann 2012-12-11 12:38:11 UTC
Created attachment 661411 [details]
File: var_log_messages

Comment 12 Jan Teichmann 2013-01-10 09:15:13 UTC
I noticed more strange memory corruption in other programs recently and as it turned out I had a defective RAM module. Effects were very random and rare but could be the cause of most memory corruption I lately reported. I assumed it is related to the beta state of F18 so I didnt suspect the RAM at first but MemTest found a small address range with errors.
I am extremely sorry for taking up your time hunting down bugs which are most likely not there. I decided to close my latest bug reports as I can not assure that the memory corruption was actually caused by the program rather than the defect RAM module.


Note You need to log in before you can comment on or make changes to this bug.