Bug 886087 - Rest query add storage domain fails on fedora18: missing /sbin/scsi_id
Rest query add storage domain fails on fedora18: missing /sbin/scsi_id
Status: CLOSED ERRATA
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
unspecified
Unspecified Unspecified
urgent Severity unspecified
: ---
: 3.2
Assigned To: Yeela Kaplan
storage
:
Depends On:
Blocks: ovirt-3.2-release
  Show dependency treegraph
 
Reported: 2012-12-11 08:43 EST by Ohad Basan
Modified: 2016-02-10 21:19 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-12 04:43:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
vdsm log (1.50 MB, text/x-log)
2012-12-27 08:41 EST, Ohad Basan
no flags Details
engine.log (239.45 KB, text/x-log)
2012-12-27 08:42 EST, Ohad Basan
no flags Details

  None (edit)
Description Ohad Basan 2012-12-11 08:43:35 EST
Description of problem:
The add storage domain rest command uses the /sbin/scsi_id binary
this file is absent on fedora18. it makes the rest query fail

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.install fedora18+ovirt engine
2.run a rest query to add an iscsi storage domain 
3.
  
Actual results:
the query will fail due to /sbin/scsi_id absent

Expected results:
storage domain should be added.

Additional info:
Comment 1 Yeela Kaplan 2012-12-26 02:29:16 EST
Ohad,
Please attach the full log: vdsm + engine.
Comment 2 Ohad Basan 2012-12-27 08:41:27 EST
Created attachment 669598 [details]
vdsm log
Comment 3 Ohad Basan 2012-12-27 08:42:06 EST
Created attachment 669599 [details]
engine.log
Comment 4 Yeela Kaplan 2013-01-09 11:20:17 EST
Change-Id: I409d4da0ba429564466271aded32e96f9401cd6c
Comment 5 Fedora Update System 2013-02-14 04:25:28 EST
vdsm-4.10.3-6.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2013-1775/vdsm-4.10.3-6.fc18
Comment 6 Fedora Update System 2013-02-14 13:29:43 EST
vdsm-4.10.3-7.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/vdsm-4.10.3-7.fc18
Comment 7 Fedora Update System 2013-02-15 20:26:04 EST
Package vdsm-4.10.3-7.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing vdsm-4.10.3-7.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-2581/vdsm-4.10.3-7.fc18
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-03-12 04:43:23 EDT
vdsm-4.10.3-7.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.