Bug 88621 - Makedev gives the wrong rights to /dev/audio* /dev/mixer* and /dev/dsp*
Summary: Makedev gives the wrong rights to /dev/audio* /dev/mixer* and /dev/dsp*
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: MAKEDEV (Show other bugs)
(Show other bugs)
Version: 9
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-11 14:53 UTC by Need Real Name
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 00:44:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2003-04-11 14:53:37 UTC
Description of problem:

By default, /dev/audio* /dev/mixer* and /dev/dsp* have the 600 rights. The owner
being root, the sound card only works for the administrator. Under Gnome for
instance, the users have no sound and no way to access the sound card.
The solution of this problem is to change the rights of /dev/audio* /dev/mixer*
and /dev/dsp* from 600 to 666. However, when the machine is rebooted, the rights
are brought back to 600. This is due to the configurations of the files in
/etc/makedev.d (The rights given to the $CONSOLE alias I think)

Version-Release number of selected component (if applicable):
MAKEDEV-3.3.2-5

How reproducible:


Steps to Reproduce:
1. chmod 666 /dev/dsp* /dev/audio* /dev/mixer* (to get sound as a user)
2. reboot
3. ls -la /dev/dsp* /dev/audio* /dev/mixer*
    
Actual results:
[root@papeete makedev.d]# ls -la /dev/dsp* /dev/audio* /dev/mixer*
crw-------    1 root     root      14,   4 Jan 30 11:24 /dev/audio
crw-------    1 root     root      14,  20 Jan 30 11:24 /dev/audio1
crw-------    1 root     root      14,   7 Jan 30 11:24 /dev/audioctl
crw-------    1 root     root      14,   3 Jan 30 11:24 /dev/dsp
crw-------    1 root     root      14,  19 Jan 30 11:24 /dev/dsp1
crw-------    1 root     root      55,   0 Jan 30 11:24 /dev/dsp56k
crw-------    1 root     root      14,   0 Jan 30 11:24 /dev/mixer
crw-------    1 root     root      14,  16 Jan 30 11:24 /dev/mixer1


Expected results:
[root@papeete makedev.d]# ls -la /dev/dsp* /dev/audio* /dev/mixer*
crw-rw-rw-    1 root     root      14,   4 Jan 30 11:24 /dev/audio
crw-rw-rw-    1 root     root      14,  20 Jan 30 11:24 /dev/audio1
crw-rw-rw-    1 root     root      14,   7 Jan 30 11:24 /dev/audioctl
crw-rw-rw-    1 root     root      14,   3 Jan 30 11:24 /dev/dsp
crw-rw-rw-    1 root     root      14,  19 Jan 30 11:24 /dev/dsp1
crw-rw-rw-    1 root     root      55,   0 Jan 30 11:24 /dev/dsp56k
crw-rw-rw-    1 root     root      14,   0 Jan 30 11:24 /dev/mixer
crw-rw-rw-    1 root     root      14,  16 Jan 30 11:24 /dev/mixer1


Additional info:
I noticed the same kind of problems with RedHat 7.3 and RedHat 8.0

Comment 1 Nalin Dahyabhai 2004-08-26 00:44:37 UTC
Permissions to use these devices are granted by pam_console when the
user logs in:  there's more information about how this is done at
http://www.redhat.com/support/wpapers/newpam/.


Note You need to log in before you can comment on or make changes to this bug.