Bug 886283 - rhsm-icon --force-icon displays the wrong icons
Summary: rhsm-icon --force-icon displays the wrong icons
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: beta
: 7.0
Assignee: William Poteat
QA Contact: IDM QE LIST
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel70
TreeView+ depends on / blocked
 
Reported: 2012-12-11 23:31 UTC by John Sefler
Modified: 2013-01-15 16:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-15 15:20:06 UTC
Target Upstream Version:


Attachments (Terms of Use)
rhsm-icon -i --force-icon=warning IS WRONG (426.12 KB, image/png)
2012-12-11 23:33 UTC, John Sefler
no flags Details
rhsm-icon -i --force-icon=expired IS WRONG (425.36 KB, image/png)
2012-12-11 23:33 UTC, John Sefler
no flags Details

Description John Sefler 2012-12-11 23:31:46 UTC
Description of problem:
The rhsm-icons displayed for --force-icon=expired and --force-icon=warning are switched.  What is displayed for "expired" should be displayed for "warning" and visa-versa.

See attached screenshots


Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# rpm -q subscription-manager-gui
subscription-manager-gui-1.1.11-1.el6.x86_64


How reproducible:


Steps to Reproduce:
[root@jsefler-6 ~]# killall rhsm-icon
[root@jsefler-6 ~]# rhsm-icon -i --force-icon=warning
[root@jsefler-6 ~]# killall rhsm-icon
[root@jsefler-6 ~]# rhsm-icon -i --force-icon=expired

Comment 1 John Sefler 2012-12-11 23:33:20 UTC
Created attachment 661784 [details]
rhsm-icon -i --force-icon=warning    IS WRONG

Comment 2 John Sefler 2012-12-11 23:33:52 UTC
Created attachment 661785 [details]
rhsm-icon -i --force-icon=expired IS WRONG

Comment 3 John Sefler 2013-01-15 16:35:37 UTC
Apologies to all...
The appearance the word "expire" in the warning icon and the lack of the word "expire" in the expired icon misled me to opening this bug.  In fact, the icons presented in attachment 661784 [details] and attachment 661785 [details] are correct.

This bug should be CLOSED as NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.