Bug 886292 - [RFE][nova] Nova change-root-password doesn't work for KVM
Summary: [RFE][nova] Nova change-root-password doesn't work for KVM
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova   
(Show other bugs)
Version: 2.1
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: Upstream M3
: 4.0
Assignee: Nikola Dipanov
QA Contact: Xavier Queralt
URL: https://blueprints.launchpad.net/nova...
Whiteboard:
Keywords: FutureFeature, OtherQA, Rebase
Depends On:
Blocks: RHOS40RFE
TreeView+ depends on / blocked
 
Reported: 2012-12-11 23:56 UTC by Graeme Gillies
Modified: 2016-04-26 22:56 UTC (History)
11 users (show)

Fixed In Version: openstack-nova-2013.2-0.21.b3.el6ost
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 23:53:24 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2013:1859 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2013-12-21 00:01:48 UTC

Description Graeme Gillies 2012-12-11 23:56:02 UTC
Hi,

I understand with the limitations of KVM why the nova change-root-password command doesn't work, but at the moment if you try and use it, it throws a massive ugly error

ERROR: InstancePasswordSetFailed_Remote: Failed to set admin password on 0def255e-9392-4b5b-adc3-97a182a990e5 because set_admin_password is not implemented by this driver.
Traceback (most recent call last):

  File "/usr/lib/python2.6/site-packages/nova/openstack/common/rpc/amqp.py", line 276, in _process_data
    rval = self.proxy.dispatch(ctxt, version, method, **args)

  File "/usr/lib/python2.6/site-packages/nova/openstack/common/rpc/dispatcher.py", line 145, in dispatch
    return getattr(proxyobj, method)(ctxt, **kwargs)

  File "/usr/lib/python2.6/site-packages/nova/exception.py", line 117, in wrapped
    temp_level, payload)

  File "/usr/lib64/python2.6/contextlib.py", line 23, in __exit__
    self.gen.next()

  File "/usr/lib/python2.6/site-packages/nova/exception.py", line 92, in wrapped
    return f(*args, **kw)

  File "/usr/lib/python2.6/site-packages/nova/compute/manager.py", line 175, in decorated_function
    pass

  File "/usr/lib64/python2.6/contextlib.py", line 23, in __exit__
    self.gen.next()

  File "/usr/lib/python2.6/site-packages/nova/compute/manager.py", line 161, in decorated_function
    return function(self, context, *args, **kwargs)

  File "/usr/lib/python2.6/site-packages/nova/compute/manager.py", line 196, in decorated_function
    kwargs['instance']['uuid'], e, sys.exc_info())

  File "/usr/lib64/python2.6/contextlib.py", line 23, in __exit__
    self.gen.next()

  File "/usr/lib/python2.6/site-packages/nova/compute/manager.py", line 190, in decorated_function
    return function(self, context, *args, **kwargs)

  File "/usr/lib/python2.6/site-packages/nova/compute/manager.py", line 1304, in set_admin_password
    instance=instance['uuid'], reason=_msg)

InstancePasswordSetFailed: Failed to set admin password on 0def255e-9392-4b5b-adc3-97a182a990e5 because set_admin_password is not implemented by this driver.
 (HTTP 500)

At the very least it should be changed to be something a bit cleaner of an error. It would be *fantastic* if we could somehow support this functionality (as a lot of people want to make use of it), though I understand technically that's a very tall order (impossible maybe?).

Do we need to look at making cloud-init or some other package have an daemon running inside the instance that talks back to the outside openstack world for dynamic updates such as this? Something cross platform that could run in Windows as well (thinking of the future) would be neat, but obviously a lot of engineering time.

Regards,

Graeme

Comment 2 Nikola Dipanov 2012-12-14 13:56:04 UTC
There seems to be some work going on upstream on this matter https://blueprints.launchpad.net/nova/+spec/get-password.

Not sure it completely fit's the bug but sees relevant - it is planned for Grizzly so setting the appropriate flags

Comment 4 Ami Jeain 2013-07-29 07:57:12 UTC
Hi Graeme,

just making sure:
you wrote that "nova change-root-password command doesn't work"m but this command doesn't exist, but rather "nova root-password <UUID>"...

is it correct?

Comment 5 Graeme Gillies 2013-07-29 22:20:39 UTC
Hi,

Yeah that is the command I'm seeing as well, either they renamed it or, more than likely, I got the name of the command wrong.

Regards,

Graeme

Comment 11 errata-xmlrpc 2013-12-19 23:53:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html


Note You need to log in before you can comment on or make changes to this bug.