This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 88644 - rsh gives error "poll: protocol failure in circuit setup"
rsh gives error "poll: protocol failure in circuit setup"
Status: CLOSED DUPLICATE of bug 59876
Product: Red Hat Linux
Classification: Retired
Component: rsh (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-11 13:51 EDT by Steve Rotolo
Modified: 2015-03-04 20:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve Rotolo 2003-04-11 13:51:58 EDT
Description of problem:

  Running lots of rsh's results in rsh failing with the error "poll: protocol
failure in circuit setup".


Version-Release number of selected component (if applicable):

  $ rpm -iqf /usr/bin/rsh
Name        : rsh                          Relocations: (not relocateable)
Version     : 0.17                              Vendor: Red Hat, Inc.
Release     : 10                            Build Date: Sun 23 Jun 2002 08:05:15
PM EDT
Install date: Fri 22 Nov 2002 04:53:14 PM EST      Build Host:
perf90.perf.redhat.com
Group       : Applications/Internet         Source RPM: rsh-0.17-10.src.rpm
Size        : 64489                            License: BSD
Signature   : DSA/SHA1, Tue 03 Sep 2002 06:36:58 PM EDT, Key ID
219180cddb42a60ePackager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Summary     : Clients for remote access (rsh, rlogin, rcp).


How reproducible:

  very


Steps to Reproduce:

1. set up a user on hostB so that user on hostA can rsh to hostB without a
password prompt

2. create the following script on hostA as "doit":

  system=${1:?}

  m=0
  while true
  do
        echo -n $m
        n=10
        while [ $n -gt 0 ]
        do
                /usr/bin/rsh $system echo hello >/dev/null &
                [ $? -ne 0 ] && exit 1
                echo -n .
                n=`expr $n - 1`
        done
        wait
        echo
        m=`expr $m + 1`
  done

3. on hostA, run: doit hostB


Actual results:

  within two minutes you get "poll: protocol failure in circuit setup" errors


Expected results:

  no errors


Additional info:
Comment 1 Phil Knirsch 2003-06-25 11:01:54 EDT

*** This bug has been marked as a duplicate of 59876 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:52:37 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.