Bug 886473 - Recording in Windows7 32bit, the "record time" will suddenly reach nearly 20 minutes in a short time.
Summary: Recording in Windows7 32bit, the "record time" will suddenly reach nearly 20...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.4
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Gerd Hoffmann
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-12 11:27 UTC by Qian Guo
Modified: 2013-04-04 09:51 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-04 09:51:23 UTC
Target Upstream Version:


Attachments (Terms of Use)
The sreenshot I captured when the recorder in windows 7 hit the bug. (87.81 KB, image/png)
2012-12-12 11:27 UTC, Qian Guo
no flags Details

Description Qian Guo 2012-12-12 11:27:41 UTC
Created attachment 662291 [details]
The sreenshot I captured when the recorder in windows 7 hit the bug.

Description of problem:
Start Windows 7 32bit guest with a intel-hda device, when during the recording, the record time would reach nearly 20 minutes in a short time(nearly 10s ), and make the record file too big to continue record. 

Version-Release number of selected component (if applicable):

1.host kernel is 2.6.32-348.el6.x86_64

2.qemu-kvm verison is qemu-kvm-0.12.1.2-2.342.el6.x86_64

3.guest os is Windows 7 32bit sp1

4.The driver version of "High Definition Audio Device " in guest is 
6.1.7601.17514

How reproducible:
100%

Steps to Reproduce:
1.Run a Windows 7 32bit sp1 guest, with a intel-hda device, e.g.
<qemu-cli>...  -device intel-hda,id=sound0,bus=pci.0,addr=0x7 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 ...

2.After Windows 7 bootup, open the "Sound Recorder", and start recording

  
Actual results:
About more than 10s, the record time reach to be 20 minutes, and since this, make the recording file too big to continue record. 
Pls see the "screenshot" I attached in this bug.

Expected results:
Sound Recorder works well in guest.

Additional info:
I test it in a Windows 7 host, which the driver of "HDA" device is the same as guest, the Sound Recorder works well.

Comment 1 Qian Guo 2012-12-12 11:29:20 UTC
Additional info:
1.The whole cli I use is :

#/usr/libexec/qemu-kvm -cpu SandyBridge -m 2G -smp 2,sockets=1,cores=2,threads=1 -M rhel6.4.0 -enable-kvm -name testnic2 -drive file=/mnt/win7-64.raw,if=none,format=raw,werror=stop,rerror=stop,cache=none,media=disk,id=drive-scsi0-disk0 -device virtio-scsi-pci,id=scsi0,addr=0x4 -device scsi-hd,scsi-id=0,lun=0,bus=scsi0.0,drive=drive-scsi0-disk0,id=virtio-disk0,bootindex=1 -nodefaults -nodefconfig -monitor stdio -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,id=virt-net0,mac=54:52:1a:32:b4:71 -device sga -chardev socket,id=serial0,path=/var/test1,server,nowait -device isa-serial,chardev=serial0 -vnc :10 -vga std -boot menu=on -device intel-hda,id=sound0,bus=pci.0,addr=0x7 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0

2.The guest is using vnc .

Comment 3 Qian Guo 2012-12-12 12:36:34 UTC
wont hit this bug with spice instead of vnc

Comment 4 Qian Guo 2012-12-14 05:27:59 UTC
Test this bug with vnc and do the same libvirt does: set QEMU_AUDIO_DRV=none.

cli like this 
#QEMU_AUDIO_DRV=none /usr/libexec/qemu-kvm ...-vnc :10 -vga std ... -device intel-hda,id=sound0,bus=pci.0,addr=0x7 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 ...

Result: The sound recorder works well, but since this "QEMU_AUDIO_DRV=on" environment, could not hear anything in guest.


Note You need to log in before you can comment on or make changes to this bug.