Bug 88651 - mozilla requires compat-gcc-c++ in comps.xml
Summary: mozilla requires compat-gcc-c++ in comps.xml
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
: 90633 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-11 18:19 UTC by Gene Czarcinski
Modified: 2007-04-18 16:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-06-29 20:51:49 UTC


Attachments (Terms of Use)

Description Gene Czarcinski 2003-04-11 18:19:41 UTC
Description of problem:

Mozilla appears to require the "old" gcc/gcc-c++ compiler and libraries. 
However, the comps.xml entry for mozilla requires compat-gcc-c++ (instead of
more likely  compat-libstdc++).  This in turn drags in compat-gcc and
glibc-devel even if no other development stuff selected.  The compat-gcc-c++ is
likely needed to build the package but not for the runtime binary packages.

Comment 1 Bill Nottingham 2003-04-11 18:31:45 UTC
Hm, this appears to have crept in when genfullcomps was run.

Comment 2 Gene Czarcinski 2003-04-11 21:41:40 UTC
Mmmm ... I thought the "comps" component was the one for reporting stuff about
the  file specifying package grouping/select.

Comment 3 Jeremy Katz 2003-04-11 21:46:50 UTC
You really don't want to know why this happens...  I'll see what I can hack up
(and yes, technically it is comps, but this is "tools surrounding comps" so it
falls more into my lap :)

Comment 4 Jeremy Katz 2003-05-16 21:26:11 UTC
This is magically fixed with rawhide (since mozilla is built with gcc 3.2) but
some heuristics changes are still needed for getfullcomps

Comment 5 Bill Nottingham 2003-05-19 16:32:05 UTC
*** Bug 90633 has been marked as a duplicate of this bug. ***

Comment 6 Jeremy Katz 2003-06-29 20:51:49 UTC
Slightly better heuristics now used.


Note You need to log in before you can comment on or make changes to this bug.