Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 886528 - FirewallD starts with "ERROR: Failed to load zone file '/etc/firewalld/zones/public.xml':"
Summary: FirewallD starts with "ERROR: Failed to load zone file '/etc/firewalld/zones/...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: firewalld
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-12 13:46 UTC by Martin
Modified: 2014-09-15 00:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-12 19:09:19 UTC
Type: Bug


Attachments (Terms of Use)

Description Martin 2012-12-12 13:46:40 UTC
Description of problem:
FirewallD starts with "ERROR: Failed to load zone file '/etc/firewalld/zones/public.xml':"

Version-Release number of selected component (if applicable):
firewalld-0.2.9-1.fc18.noarch

How reproducible:
always

Steps to Reproduce:
1. systemctl start firewalld.service
2. systemctl status firewalld.service
  
Actual results:
systemctl status firewalld.service
firewalld.service - firewalld - dynamic firewall daemon
	  Loaded: loaded (/usr/lib/systemd/system/firewalld.service; enabled)
	  Active: active (running) since Wed, 2012-12-12 14:42:52 CET; 3min 15s ago
	Main PID: 20329 (firewalld)
	  CGroup: name=systemd:/system/firewalld.service
		  └ 20329 /usr/bin/python -Es /usr/sbin/firewalld --nofork

Dec 12 14:42:52 dhcp-28-241.brq.redhat.com systemd[1]: Started firewalld - dynamic firewall daemon.
Dec 12 14:42:54 dhcp-28-241.brq.redhat.com firewalld[20329]: 2012-12-12 14:42:54 ERROR: Failed to load zone file '/etc/firewalld/zones/public.xml':

Expected results:
no erros

Comment 1 Thomas Woerner 2012-12-12 14:03:23 UTC
Please attach the zone file /etc/firewalld/zones/public.xml

Comment 2 Martin 2012-12-12 14:18:02 UTC
/etc/firewalld/zones/public.xml:

<?xml version="1.0" encoding="utf-8"?>
<zone name="public">
  <short>Public</short>
  <description>For use in public areas. You do not trust the other computers on networks to not harm your computer. Only selected incoming connections are accepted.</description>

Comment 3 Thomas Woerner 2012-12-12 14:20:15 UTC
This is only half of a valid file, therefore the error.

Comment 4 Jiri Popelka 2012-12-12 19:09:19 UTC
Closing this per the following IRC discussion

<twoerner>	Martix: this file is not provided by firewalld
<twoerner>	/etc/firewalld/zones is for user created or customized zones
<twoerner>	where have you got this file?
<twoerner>	you can remove it btw
<Martix>	twoerner: I don't know, I'm running updated F18. upgraded from F17
<Martix>	yum whatprovides can't find a match
<twoerner>	Martix: please remove the file
<Martix>	ok


Note You need to log in before you can comment on or make changes to this bug.