Bug 886540 - [RFE] UI should show more feedback and update the screen based on actions results
Summary: [RFE] UI should show more feedback and update the screen based on actions res...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: luci
Version: 6.4
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Ryan McCabe
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-12 14:08 UTC by Jaroslav Kortus
Modified: 2015-10-21 22:33 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-21 22:33:43 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jaroslav Kortus 2012-12-12 14:08:49 UTC
Description of problem:
Let's take leaving the cluster as an example.
If I click the nodes and press "Leave Cluster", all I get immediately is blue bar on top saying it's stopping nodes.

Then after a while some popups appear telling me if it succeeded or not. And if I dismiss them, I still have to reload the page to see the actual status.

It would be better if the actions were reflected in the UI from the start. That means that if any action is pending, it's visible somewhere.

Expected behaviour would be:
1. I click on the "Leave Cluster" button.
2. Then I'm informed that 3 actions (in 3-node cluster) are pending. Ideally, these would be reflected directly on the row corresponding to each node.
3. After the action is done, the respective row is updated (and possibly a popup appears, but updating some new status box on a page would be preferred).
4. I should also be informed should any action time out.

By implementing this approach I cloud clearly see the current status all the time from the beginning. Currently the pop-ups are more like a surprise :).

This approach could be used also for other operations/dialogs that can be reflected in the UI in a similar way.

Version-Release number of selected component (if applicable):
luci-0.26.0-31.el6.x86_64

Comment 2 RHEL Program Management 2012-12-16 06:49:30 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 3 Jan Pokorný [poki] 2012-12-21 15:10:12 UTC
Hmm, reading this, I got an idea of extra screen, call it "Jobs", where you
cloud (sic) get an overview asynchronous jobs being performed including
the current progress ("step X out Y", "finished: A, B, remaining: C, D",
etc.).  I think it would also be easier to implement as integrating
of such information into existing screens sounds as quite a complex task.

Comment 4 Jan Pokorný [poki] 2012-12-21 15:14:55 UTC
+ a navigation to this "Jobs" screen would be provided within existing
  one-off messages upon triggering asynchronous. 

Thoughts?

Comment 5 Chris Feist 2015-10-21 22:33:43 UTC
Closing this bz due to capacity constraints in 6.8 (and this should not be an issue with the pcs UI in RHEL 7).


Note You need to log in before you can comment on or make changes to this bug.