Bug 886570 - All "windows" have the same resolution in fullscreen
All "windows" have the same resolution in fullscreen
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.4
Unspecified Unspecified
urgent Severity high
: rc
: ---
Assigned To: Hans de Goede
Virtualization Bugs
: Regression, TestBlocker, ZStream
: 894141 (view as bug list)
Depends On:
Blocks: 1009648 918570
  Show dependency treegraph
 
Reported: 2012-12-12 10:15 EST by Tomas Jamrisko
Modified: 2013-11-21 03:05 EST (History)
18 users (show)

See Also:
Fixed In Version: virt-viewer-0.5.6-1.el6
Doc Type: Bug Fix
Doc Text:
Previously, when switched to full-screen, multiple monitor displays in both client and guest appeared to have the same resolution, even though the monitors were different. With this update, monitors display resolution according to their capacity
Story Points: ---
Clone Of:
: 913206 (view as bug list)
Environment:
Last Closed: 2013-11-21 03:05:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Jamrisko 2012-12-12 10:15:38 EST
Description of problem:
Opening having two displays both in client and guest and switching to fullscreen sets all displays on guest to the same resolution(and scales if necessary), even though clients displays are different

This is pretty heavily related to https://bugzilla.redhat.com/show_bug.cgi?id=881020

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-18.el6.x86_64


How reproducible:
Always

Steps to Reproduce:
1. Get a client with two physical monitors, each with different resolutions
2. Connect to a RHEL64 VM
3. Open a second display (View -> Displays -> whatever)
4. Click View -> Full screen
5. Wait

  
Actual results:
Both screens have the same resolution

Expected results:
The guest displays should have the same resolution as client screen on which they are displayed
Comment 2 Geyang Kong 2012-12-17 01:35:56 EST
Hit another problem with 3-4 displays, I'm not quite sure if it's related with this bug, add a comment here for a record, if necessary to report a new bug, please tell me.

Steps:
1. Have a host with 3 or 4 displays.(more than 2)
2. Install a RHEL6.4 guest, with spice+qxl device, and spicevmc channel exists.
3. Start the guest and make sure spice-vdagentd is running.
4. Run #remote-viewer spice://127.0.0.1:5900 --full-screen=auto-conf

Actual restult:
1. Only 1 display was launched.

Expected result:
1. 3 or 4 display launched.

Additional, if I disable 3rd and 4th displays, command in step 4 works well, there will be 2 displays with full screen mode.
Comment 3 RHEL Product and Program Management 2012-12-20 01:47:22 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 Tomas Jamrisko 2013-01-11 09:59:41 EST
*** Bug 894141 has been marked as a duplicate of this bug. ***
Comment 6 Geyang Kong 2013-01-21 23:58:01 EST
This issue can be reproduced by RHEL6u4-SNAP4.

Steps:
Same as Description

Actual Result:
2 screen have one resolution.
Comment 7 David Blechter 2013-01-28 13:09:23 EST
Sorry, missed justification on moving this blocker bug to 6.5.

Justification:

It was based on the description of the bug:
"...This is pretty heavily related to https://bugzilla.redhat.com/show_bug.cgi?id=881020 ..." that was moved to 6.5  :

https://bugzilla.redhat.com/show_bug.cgi?id=881020#c29: 
Dave Allan 2013-01-08 21:50:28 EST
<acathrow> we can move it out from blocker to 'asap'
I'm moving this BZ to 6.5 and requesting z-stream.
Comment 10 Hans de Goede 2013-01-30 13:59:31 EST
This is fixed by this patch, which has been pushed upstream recently:
https://www.redhat.com/archives/virt-tools-list/2013-January/msg00027.html

Moving to post.
Comment 19 CongDong 2013-07-07 22:31:30 EDT
I can't reproduce this bug with virt-viewer-0.5.2-18.el6.x86_64

Steps:
same as description.

The resolution is different in the two displays.

And it works well when I use virt-viewer-0.5.6-1.el6.

BTW, when I do this with 4 displays, I found the resolution is not the same in 4 displays, but the resolution isn't right, it's same with the physical display.
Comment 20 CongDong 2013-07-08 08:13:12 EDT
Hi:
I can't reproduce this bug with virt-viewer-0.5.2-18.el6.x86_64

Steps:
1. # virsh start T1
2. virt-viewer T1
3. Open a second display (View -> Displays -> whatever)
4. Click View -> Full screen
5. Check the resolution.

Result:
The resolution is ok, two screens' resolution are diffenent.

The steps are same with description, did I missed something?
Comment 21 Tomas Jamrisko 2013-07-08 08:39:15 EDT
Hi, if you had two monitors on client, then you probably haven't missed anything. Just to make sure though: 
- vdagent has to be running and working on the guest
- check the version again. My guess is that you're running updated virt-viewer from z-stream, in which this bug was fixed -- https://bugzilla.redhat.com/show_bug.cgi?id=918570
Comment 22 CongDong 2013-07-10 03:14:21 EDT
(In reply to Tomas Jamrisko from comment #21)
> Hi, if you had two monitors on client, then you probably haven't missed
> anything. Just to make sure though: 
> - vdagent has to be running and working on the guest
> - check the version again. My guess is that you're running updated
> virt-viewer from z-stream, in which this bug was fixed --
> https://bugzilla.redhat.com/show_bug.cgi?id=918570

Thanks for your help, I can reproduce this , but the environment is same with comment 20 . 

After I do the steps as comment 20, I saw both screens have the same resolution.

Verify:
version:
virt-viewer-0.5.6-1.el6

Steps:
1. Get a client with two physical monitors, each with different resolutions
2. Connect to a RHEL64 VM
3. Open a second display (View -> Displays -> whatever)
4. Click View -> Full screen on each window
5. check the resolution

Result:
After step5, the resolution of the two displays are diffenent, but it's not right.
I have two physical displays 'A' and 'B'.
The guest have two displays 'a' and 'b'

If the resolution like this: 'A' = 'a', 'B' = 'b' , this is right.
But the result is:
'A' = 'b'  'B' = 'a'.
As the result, change to ASSINGED.
Comment 23 Hans de Goede 2013-09-20 04:16:22 EDT
(In reply to CongDong from comment #22)
> (In reply to Tomas Jamrisko from comment #21)
> > Hi, if you had two monitors on client, then you probably haven't missed
> > anything. Just to make sure though: 
> > - vdagent has to be running and working on the guest
> > - check the version again. My guess is that you're running updated
> > virt-viewer from z-stream, in which this bug was fixed --
> > https://bugzilla.redhat.com/show_bug.cgi?id=918570
> 
> Thanks for your help, I can reproduce this , but the environment is same
> with comment 20 . 
> 
> After I do the steps as comment 20, I saw both screens have the same
> resolution.
> 
> Verify:
> version:
> virt-viewer-0.5.6-1.el6
> 
> Steps:
> 1. Get a client with two physical monitors, each with different resolutions
> 2. Connect to a RHEL64 VM
> 3. Open a second display (View -> Displays -> whatever)
> 4. Click View -> Full screen on each window
> 5. check the resolution
> 
> Result:
> After step5, the resolution of the two displays are diffenent, but it's not
> right.
> I have two physical displays 'A' and 'B'.
> The guest have two displays 'a' and 'b'
> 
> If the resolution like this: 'A' = 'a', 'B' = 'b' , this is right.
> But the result is:
> 'A' = 'b'  'B' = 'a'.
> As the result, change to ASSINGED.

I've just tried to reproduce this and I cannot reproduce this. Maybe you've arranged the remote-viewer windows so that window (1) is on physical display 2 and window (2) is on physical display 1? Then you will get what you describe, but this is intentional as the virtual monitor is resized to be the same size as the window, so if the window for virtual monitor 1 is on physical monitor 2, it will get the size of physical display 2.

Also what version of the agent are you using in the vm ?
Comment 24 CongDong 2013-09-21 23:06:34 EDT
In comment 22, virtual monitor 1 is on physical monitor 1, but the resolution is same with physical monitor 2,  but virt-viewer-0.5.6-1.el6 is deleted on brewweb,so I can't reproduce the result in comment 22.

I tested with:
virt-viewer-0.5.6-2.el6.x86_64
spice-vdagent-0.14.0-2.el6.x86_64.rpm

Steps are same with comment 22:
1. Get a client with two physical monitors, each with different resolutions
2. Connect to a RHEL64 VM
3. Open a second display (View -> Displays -> whatever)
4. Click View -> Full screen on each window
5. check the resolution

Result:
The guest displays have the same resolution as client screen on which they are displayed

The result is right, and virt-viewer works well, so change the status to VERIFIED.
Comment 25 errata-xmlrpc 2013-11-21 03:05:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1578.html

Note You need to log in before you can comment on or make changes to this bug.