This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 88659 - doing rpm -U updates-80/*.rpm tries kernel 2x
doing rpm -U updates-80/*.rpm tries kernel 2x
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
8.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-11 14:41 EDT by Need Real Name
Modified: 2007-04-18 12:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-14 10:46:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-04-11 14:41:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
rpm, at least when used casually, complains too much about
installation issues.  It may be a package prob (kernel vs kernel-BOOT), or a
packaging problem (ie no way to mark those
2 as mutually exclusive), or an rpm problem (has enough info
to silence these complaints, but doesnt do so)

[root@homer rpms]# rpm -U *.rpm
 ...
        package kernel-2.4.18-27.8.0 is already installed
...
        file /boot/System.map-2.4.18-27.8.0 from install of kernel-2.4.18-27.8.0
conflicts with file from package kernel-2.4.18-27.8.0
        file /boot/config-2.4.18-27.8.0 from install of kernel-2.4.18-27.8.0
conflicts with file from package kernel-2.4.18-27.8.0


[root@homer rpms]# ls kernel-*
kernel-2.4.18-27.8.0.i386.rpm       kernel-doc-2.4.18-27.8.0.i386.rpm
kernel-BOOT-2.4.18-27.8.0.i386.rpm  kernel-source-2.4.18-27.8.0.i386.rpm


Version-Release number of selected component (if applicable):
rpm-4.1-1.06

How reproducible:
Didn't try

Steps to Reproduce:
1. download all updates/8.0/en/i386/*
2. cd to local dir
3. rpm -U *.rpm
    

Expected Results:  i expected the 'already installed' message

Additional info:
Comment 1 Jeff Johnson 2003-04-14 10:46:16 EDT
There is no way in general for rpm to understand what kernel is intended
when you do
    rpm -Uvh yadda/yadda/kernel*.rpm
Install the kernel that you want manually.

Note You need to log in before you can comment on or make changes to this bug.