Bug 886604 - etc/yum.repos.d/ does not exist, turning manage_repos off.
etc/yum.repos.d/ does not exist, turning manage_repos off.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity urgent
: rc
: ---
Assigned To: Adrian Likins
IDM QE LIST
: Regression
Depends On:
Blocks: 771481 888457
  Show dependency treegraph
 
Reported: 2012-12-12 11:29 EST by John Sefler
Modified: 2013-02-21 04:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 04:03:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-12-12 11:29:53 EST
Description of problem:
The 


Version-Release number of selected component (if applicable):
[root@jsefler-6workstation ~]# rpm -q python-rhsm subscription-manager
python-rhsm-1.1.7-1.git.0.7233e22.el6.x86_64
subscription-manager-1.1.12-1.git.0.914807f.el6.x86_64


How reproducible:


Steps to Reproduce:
1. register and consume an entitlement that provides content, then...
2. run subscription-manager repos --list and get a non empty list like this...
+----------------------------------------------------------+
    Available Repositories in /etc/yum.repos.d/redhat.repo
+----------------------------------------------------------+
Repo Id:              	awesomeos-ppc
Repo Name:            	awesomeos-ppc
Repo Url:             	https://cdn.redhat.com/path/to/awesomeos/ppc
Enabled:              	0

Repo Id:              	always-enabled-content
Repo Name:            	always-enabled-content
Repo Url:             	https://cdn.redhat.com/foo/path/always/$releasever
Enabled:              	1

Repo Id:              	never-enabled-content
Repo Name:            	never-enabled-content
Repo Url:             	https://cdn.redhat.com/foo/path/never
Enabled:              	0

Repo Id:              	content-label-empty-gpg
Repo Name:            	content-emptygpg
Repo Url:             	https://cdn.redhat.com/foo/path
Enabled:              	1

3. then run yum repolist and we should see these repos in the list...
[root@jsefler-6workstation ~]# yum repolist
Loaded plugins: product-id, refresh-packagekit, security, subscription-manager
This system is receiving updates from Red Hat Subscription Management.
repolist: 0
[root@jsefler-6workstation ~]# 

^^^ NOTHING IN THE LIST.  THIS IS A BUG.


Additional info:
[root@jsefler-6workstation ~]# subscription-manager config --list | grep manage
   manage_repos = [1]
   manage_repos = [1]
   manage_repos = [1]
                   ^ IT IS TURNED ON!  BUT THE rhsm.log SAYS OTHERWISE...
           
[root@jsefler-6workstation ~]# tail -f /var/log/rhsm/rhsm.log
2012-12-12 11:19:46,377 [DEBUG]  @connection.py:394 - Response status: 200
2012-12-12 11:19:46,386 [WARNING]  @repolib.py:456 - etc/yum.repos.d/ does not exist, turning manage_repos off.
2012-12-12 11:19:46,429 [DEBUG]  @repolib.py:197 - Missing required tag 'TAG1', skipping content: tagged-content
2012-12-12 11:19:46,430 [DEBUG]  @repolib.py:197 - Missing required tag 'TAG2', skipping content: tagged-content
2012-12-12 11:19:46,445 [DEBUG]  @repolib.py:469 - Skipping write due to manage_repos setting: /etc/yum.repos.d/redhat.repo
2012-12-12 11:19:46,446 [INFO]  @repolib.py:158 - repos updated: 13



I suspect an error in the fix for bug 878820
https://bugzilla.redhat.com/show_bug.cgi?id=878820#c13
https://bugzilla.redhat.com/show_bug.cgi?id=878820#c14
Comment 2 Adrian Likins 2012-12-12 11:38:27 EST
in master:

commit e33ddd689e9e22dfbf4bf14f13e1f2e23562b2e5
Author: Adrian Likins <alikins@redhat.com>
Date:   Wed Dec 12 11:27:18 2012 -0500

    886604: Fix incorrect path in repos.d check
    
    This was checking for "etc/yum.repos.d/", without the
    root/chroot expansion. This was causing no repos to get created.
    Change to use expanded path ("/etc/yum.repos.d" by default)
Comment 5 Shwetha Kallesh 2012-12-14 01:15:40 EST
Marking verified!!


[root@rhel-64-server ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.7.21-1
subscription-manager: 1.1.15-1.el6
python-rhsm: 1.1.7-1.el6


[root@rhel-64-server ~]# subscription-manager config --list | grep manage
   manage_repos = [1]
   manage_repos = [1]
   manage_repos = [1]

[root@rhel-64-server ~]# subscription-manager repos --list
+----------------------------------------------------------+
    Available Repositories in /etc/yum.repos.d/redhat.repo
+----------------------------------------------------------+
Repo Id:              	awesomeos
Repo Name:            	awesomeos
Repo Url:             	https://cdn.redhat.com/path/to/$basearch/$releasever/awesomeos
Enabled:              	1

Repo Id:              	awesomeos-x86_64
Repo Name:            	awesomeos-x86_64
Repo Url:             	https://cdn.redhat.com/path/to/awesomeos/x86_64
Enabled:              	0

Repo Id:              	awesomeos-modifier
Repo Name:            	awesomeos-modifier
Repo Url:             	http://example.com/awesomeos-modifier
Enabled:              	1

Repo Id:              	awesomeos-ppc
Repo Name:            	awesomeos-ppc
Repo Url:             	https://cdn.redhat.com/path/to/awesomeos/ppc
Enabled:              	0

Repo Id:              	always-enabled-content
Repo Name:            	always-enabled-content
Repo Url:             	https://cdn.redhat.com/foo/path/always/$releasever
Enabled:              	1

Repo Id:              	never-enabled-content
Repo Name:            	never-enabled-content
Repo Url:             	https://cdn.redhat.com/foo/path/never
Enabled:              	0

Repo Id:              	content-label-empty-gpg
Repo Name:            	content-emptygpg
Repo Url:             	https://cdn.redhat.com/foo/path
Enabled:              	1

Repo Id:              	awesomeos-s390x
Repo Name:            	awesomeos-s390x
Repo Url:             	https://cdn.redhat.com/path/to/awesomeos/s390x
Enabled:              	0

Repo Id:              	content-label-no-gpg
Repo Name:            	content-nogpg
Repo Url:             	https://cdn.redhat.com/foo/path
Enabled:              	1

Repo Id:              	awesomeos-ia64
Repo Name:            	awesomeos-ia64
Repo Url:             	https://cdn.redhat.com/path/to/awesomeos/ia64
Enabled:              	0

Repo Id:              	awesomeos-ppc64
Repo Name:            	awesomeos-ppc64
Repo Url:             	https://cdn.redhat.com/path/to/awesomeos/ppc64
Enabled:              	0

Repo Id:              	awesomeos-i686
Repo Name:            	awesomeos-i686
Repo Url:             	https://cdn.redhat.com/path/to/awesomeos/i686
Enabled:              	0

Repo Id:              	content-label
Repo Name:            	content
Repo Url:             	https://cdn.redhat.com/foo/path
Enabled:              	1

Repo Id:              	awesomeos-x86
Repo Name:            	awesomeos-x86
Repo Url:             	https://cdn.redhat.com/path/to/awesomeos/$releasever/x86
Enabled:              	0


[root@rhel-64-server ~]# yum repolist
Loaded plugins: product-id, refresh-packagekit, rhnplugin, security, subscription-manager
This system is receiving updates from Red Hat Subscription Management.
This system is not registered with RHN Classic or RHN Satellite.
You can use rhn_register to register.
RHN Satellite or RHN Classic support will be disabled.
https://cdn.redhat.com/foo/path/always/6Server/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 403 Forbidden"
Trying other mirror.
repo id                                                                repo name                                                              status
always-enabled-content                                                 always-enabled-content                                                 0
awesomeos                                                              awesomeos                                                              0
awesomeos-modifier                                                     awesomeos-modifier                                                     0
content-label                                                          content                                                                0
content-label-empty-gpg                                                content-emptygpg                                                       0
content-label-no-gpg                                                   content-nogpg                                                          0
repolist: 0
Comment 7 errata-xmlrpc 2013-02-21 04:03:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.