Bug 88662 - desktop-file-validate stops checking if the Encoding key is present
desktop-file-validate stops checking if the Encoding key is present
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: desktop-file-utils (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-11 14:46 EDT by Ville Skyttä
Modified: 2007-04-18 12:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-30 16:20:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Continue checking even if Encoding is present... :) (343 bytes, patch)
2003-04-11 14:48 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2003-04-11 14:46:19 EDT
desktop-file-validate from desktop-file-utils-0.3-5 incorrectly stops checking
if the Encoding key is present in the checked .desktop file, no matter if the
value is correct or not.

This is due to a spurious "return FALSE" statement that should be either in the
same block as the fatal error output about the invalid encoding, or just plain
removed.  I think the latter approach is the correct one.

I'll attach a patch, please apply.
Comment 1 Ville Skyttä 2003-04-11 14:48:26 EDT
Created attachment 91078 [details]
Continue checking even if Encoding is present... :)
Comment 2 Havoc Pennington 2003-04-11 17:15:45 EDT
Fixed in CVS now, thanks very much:

2003-04-11  Havoc Pennington  <hp@redhat.com>

	* src/validate.c (required_keys): don't stop checking as soon as
	we see an Encoding field. Fix from Ville Skytta
	<ville.skytta@iki.fi>

Leaving the bug open so I remember to build in rawhide.
Comment 3 Havoc Pennington 2003-07-30 16:20:45 EDT
Alex or Jonathan already built this in rawhide I believe.

Note You need to log in before you can comment on or make changes to this bug.