Bug 886629 - [abrt] python-2.7.3-13.fc18: Process /usr/bin/python2.7 was killed by signal 11 (SIGSEGV)
Summary: [abrt] python-2.7.3-13.fc18: Process /usr/bin/python2.7 was killed by signal ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: python
Version: 18
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:4d2625dcea272d9d7cb10f82589...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-12 17:23 UTC by Jan Teichmann
Modified: 2013-01-10 09:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-10 09:11:03 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (32.92 KB, text/plain)
2012-12-12 17:23 UTC, Jan Teichmann
no flags Details
File: build_ids (328 bytes, text/plain)
2012-12-12 17:24 UTC, Jan Teichmann
no flags Details
File: cgroup (156 bytes, text/plain)
2012-12-12 17:24 UTC, Jan Teichmann
no flags Details
File: environ (326 bytes, text/plain)
2012-12-12 17:24 UTC, Jan Teichmann
no flags Details
File: limits (1.29 KB, text/plain)
2012-12-12 17:24 UTC, Jan Teichmann
no flags Details
File: maps (3.54 KB, text/plain)
2012-12-12 17:24 UTC, Jan Teichmann
no flags Details
File: open_fds (392 bytes, text/plain)
2012-12-12 17:24 UTC, Jan Teichmann
no flags Details
File: proc_pid_status (890 bytes, text/plain)
2012-12-12 17:24 UTC, Jan Teichmann
no flags Details

Description Jan Teichmann 2012-12-12 17:23:55 UTC
Version-Release number of selected component:
python-2.7.3-13.fc18

Additional info:
backtrace_rating: 4
cmdline:        /usr/bin/python -u /usr/bin/abrt-action-list-dsos -m maps -o dso_list
executable:     /usr/bin/python2.7
kernel:         3.6.9-4.fc18.x86_64
uid:            0

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 ??
 #1 visit_decref at /usr/src/debug/Python-2.7.3/Modules/gcmodule.c:320
 #2 func_traverse at /usr/src/debug/Python-2.7.3/Objects/funcobject.c:479
 #4 subtract_refs at /usr/src/debug/Python-2.7.3/Modules/gcmodule.c:345
 #5 collect at /usr/src/debug/Python-2.7.3/Modules/gcmodule.c:874
 #6 collect_generations at /usr/src/debug/Python-2.7.3/Modules/gcmodule.c:996
 #7 _PyObject_GC_Malloc at /usr/src/debug/Python-2.7.3/Modules/gcmodule.c:1457
 #9 _PyObject_GC_New at /usr/src/debug/Python-2.7.3/Modules/gcmodule.c:1467
 #10 PyWrapper_New at /usr/src/debug/Python-2.7.3/Objects/descrobject.c:1068
 #11 wrapperdescr_get at /usr/src/debug/Python-2.7.3/Objects/descrobject.c:161

Comment 1 Jan Teichmann 2012-12-12 17:23:58 UTC
Created attachment 662531 [details]
File: backtrace

Comment 2 Jan Teichmann 2012-12-12 17:24:00 UTC
Created attachment 662532 [details]
File: build_ids

Comment 3 Jan Teichmann 2012-12-12 17:24:02 UTC
Created attachment 662533 [details]
File: cgroup

Comment 4 Jan Teichmann 2012-12-12 17:24:04 UTC
Created attachment 662534 [details]
File: environ

Comment 5 Jan Teichmann 2012-12-12 17:24:06 UTC
Created attachment 662535 [details]
File: limits

Comment 6 Jan Teichmann 2012-12-12 17:24:08 UTC
Created attachment 662536 [details]
File: maps

Comment 7 Jan Teichmann 2012-12-12 17:24:10 UTC
Created attachment 662537 [details]
File: open_fds

Comment 8 Jan Teichmann 2012-12-12 17:24:12 UTC
Created attachment 662538 [details]
File: proc_pid_status

Comment 9 Jan Teichmann 2013-01-10 09:11:03 UTC
I noticed more strange memory corruption in other programs recently and as it turned out I had a defective RAM module. Effects were very random and rare but could be the cause of most memory corruption I lately reported. I assumed it is related to the beta state of F18 so I didnt suspect the RAM at first but MemTest found a small address range with errors.
I am extremely sorry for taking up your time hunting down bugs which are most likely not there. I decided to close my latest bug reports as I can not assure that the memory corruption was actually caused by the program rather than the defect RAM module.


Note You need to log in before you can comment on or make changes to this bug.