Bug 886656 - HA backup broker does not properly increment the alternate exchange user count
HA backup broker does not properly increment the alternate exchange user count
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
Development
Unspecified Unspecified
medium Severity unspecified
: 2.3
: ---
Assigned To: Alan Conway
MRG Quality Engineering
: OtherQA
Depends On: 886262
Blocks: 698367
  Show dependency treegraph
 
Reported: 2012-12-12 14:54 EST by Jason Dillaman
Modified: 2013-03-19 12:40 EDT (History)
4 users (show)

See Also:
Fixed In Version: qpid-cpp-0.18-14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-19 12:40:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add a unit test reproducer (2.81 KB, patch)
2012-12-12 14:55 EST, Jason Dillaman
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-4509 None None None Never

  None (edit)
Description Jason Dillaman 2012-12-12 14:54:28 EST
Description of problem:
When an exchange or queue that utilizes an alternate exchange is replicated to a backup broker, the backup broker does not increment the user count on the alternate exchange.  This will incorrectly allow an alternate exchange to be deleted when it is still in use and will incorrectly prevent a exchange from being deleted when it is no longer an alternate exchange.

Version-Release number of selected component (if applicable):
Qpid 0.18

How reproducible:
100%

Steps to Reproduce:
1. Start primary and backup HA brokers
2. Create an exchange to use as the alternate
3. Create a queue or exchange w/ the alternate set to the previously create exchange
4. Fail the primary and promote the backup
5. Delete the alternate exchange
  
Actual results:
The alternate exchange is deleted while still in use

Expected results:
The client should receive a not-allowed exception

Additional info:
Comment 1 Jason Dillaman 2012-12-12 14:55:07 EST
Created attachment 662585 [details]
Patch to add a unit test reproducer
Comment 3 Alan Conway 2012-12-20 15:08:32 EST
Seeing some problems that may be due to this fix in testing. Marking this bug ASSIGNED again.

Note You need to log in before you can comment on or make changes to this bug.