Bug 886680 - f18 anaconda netinstall waiting too long in the welcome screen and then accepting fate causes the main hub to be unresponsive until INSTALLATION SOURCE finishes setting up CLOSEST MIRROR
Summary: f18 anaconda netinstall waiting too long in the welcome screen and then accep...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 18
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-12 21:07 UTC by Reartes Guillermo
Modified: 2013-05-13 15:48 UTC (History)
6 users (show)

Fixed In Version: anaconda-19.10-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-13 15:48:36 UTC
Type: Bug


Attachments (Terms of Use)

Description Reartes Guillermo 2012-12-12 21:07:37 UTC
Description of problem:

If one waits long enough in the 'welcome screen' when one clicks 'accept fate' and enters the 'main hub' it is unresponsive until CLOSEST MIRROR is setup by INSTALLATION SOURCE.

It is annoying but it also seems to be harmless.


Version-Release number of selected component (if applicable):
F18 (smoke5) anaconda: 18.37

How reproducible:
always, if one waits on the welcome screen long enough

Steps to Reproduce:

0. Boot anaconda and reach the 'welcome screen'

WAIT SOME TIME (+10 MIN) IN THE 'welcome screen'

1. 'Accept Fate'

Anaconda is unresponsive until INSTALLATION SOURCE finishes
configuring CLOSEST MIRROR (this is a netinstall iso)

In this case, i had to wait only 2 MIN for it (since i had to
make a phone call), but normally it takes quite some time 
for the CLOSEST MIRROR to be setup. (100kib/s connection).
  
Actual results:
anaconda is unresponsive until INSTALLATION SOURCE finishes
setting up CLOSEST MIRROR. It is not possible to enter STORAGE
INSTALLATION DESTINATION 

Expected results:
setting up CLOSEST MIRROR should not make the UI lag nor make it
unresponsive, even for a 'short' moment.

Additional info:

Comment 1 Chris Lumens 2012-12-14 15:17:40 UTC
I think we see this everywhere, not just in the welcome screen.  I know I've seen big pauses when doing what should be quick actions on storage, for instance.

Comment 2 Adam Williamson 2013-05-12 17:03:50 UTC
Reartes, can you reproduce this with current F19 builds? It's marked as having been fixed in anaconda 19.10. Thanks!

Comment 3 Reartes Guillermo 2013-05-13 15:44:19 UTC
I appears to have been fixed.

Comment 4 Adam Williamson 2013-05-13 15:48:36 UTC
Great! Thanks.


Note You need to log in before you can comment on or make changes to this bug.