Bug 88675 - (NET AIRO ?)Critical: kernel BUG at skbuff.c:315!
(NET AIRO ?)Critical: kernel BUG at skbuff.c:315!
Status: CLOSED DUPLICATE of bug 83363
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-11 15:34 EDT by Murtuza Lightwala
Modified: 2013-07-02 22:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Murtuza Lightwala 2003-04-11 15:34:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
Apr 11 11:39:53 localhost kernel: ------------[ cut here ]------------
Apr 11 11:39:53 localhost kernel: kernel BUG at skbuff.c:315!
Apr 11 11:39:53 localhost kernel: invalid operand: 0000
Apr 11 11:39:53 localhost kernel: maestro3 ac97_codec soundcore ide-cd cdrom
parport_pc lp parport autofs airo_cs airo ds yenta_socket pcmcia_core e100
ipt_REJECT iptable_filter ip_tables ohci
Apr 11 11:39:53 localhost kernel: CPU:    0
Apr 11 11:39:53 localhost kernel: EIP:    0060:[<c01f1994>]    Not tainted
Apr 11 11:39:53 localhost kernel: EFLAGS: 00210282
Apr 11 11:39:53 localhost kernel: 
Apr 11 11:39:53 localhost kernel: EIP is at __kfree_skb [kernel] 0x144 (2.4.20-9)
Apr 11 11:39:53 localhost kernel: eax: 00000045   ebx: c9fe0180   ecx: 00000001
  edx: cf12a000
Apr 11 11:39:53 localhost kernel: esi: cffdbf90   edi: cffda306   ebp: cffda000
  esp: cffdbf78
Apr 11 11:39:53 localhost kernel: ds: 0068   es: 0068   ss: 0068
Apr 11 11:39:53 localhost kernel: Process keventd (pid: 2, stackpage=cffdb000)
Apr 11 11:39:53 localhost kernel: Stack: c0275480 c01219fa cffda306 cffdbf90
c01219fa c9fe0180 cfaf02e4 cfaf02e4 
Apr 11 11:39:53 localhost kernel:        00000001 c025e19b c012b9a3 c030ca70
cffdbfb0 00000000 00000001 00000000 
Apr 11 11:39:53 localhost kernel:        cffe9f90 00010000 00000000 c012b890
00000000 c036945c 00000000 cffda000 
Apr 11 11:39:53 localhost kernel: Call Trace:   [<c01219fa>] __run_task_queue
[kernel] 0x5a (0xcffdbf7c))
Apr 11 11:39:53 localhost kernel: [<c01219fa>] __run_task_queue [kernel] 0x5a
(0xcffdbf88))
Apr 11 11:39:53 localhost kernel: [<c012b9a3>] context_thread [kernel] 0x113
(0xcffdbfa0))
Apr 11 11:39:53 localhost kernel: [<c012b890>] context_thread [kernel] 0x0
(0xcffdbfc4))
Apr 11 11:39:53 localhost kernel: [<c012b890>] context_thread [kernel] 0x0
(0xcffdbfe0))
Apr 11 11:39:53 localhost kernel: [<c010742d>] kernel_thread_helper [kernel] 0x5
(0xcffdbff0))
Apr 11 11:39:53 localhost kernel: 
Apr 11 11:39:53 localhost kernel: 
Apr 11 11:39:53 localhost kernel: Code: 0f 0b 3b 01 73 42 27 c0 8b 5c 24 14 e9
be fe ff ff 8d 74 26 
Apr 11 11:39:53 localhost kernel:  <3>airo: BAP error 4000 2
Apr 11 11:39:53 localhost kernel: airo: BAP error 4000 2
Apr 11 11:39:53 localhost kernel: airo: BAP error 4000 2
Apr 11 11:40:44 localhost apmd[1588]: Now using AC Power
Apr 11 11:52:40 localhost syslogd 1.4.1: restart.

Version-Release number of selected component (if applicable):
kernel-2.4.20-9

How reproducible:
Always

Steps to Reproduce:
1. Start X windows and  keyboard stops responding after couple of minutes
2. Eventually leading to total freeze and all I can do is powerdown
3.
    

Additional info:
Comment 1 Aaron Baer 2003-04-14 18:03:57 EDT
Not sure if this is the correct place to post this however this is happening to
me as well .. Dell c640 p4 2.4.. 

I'm having thoughts that this is being caused by the airo driver.. it's happened
to me about 5 times in the last 24 hours.. each time it seems to be around when
the card asks to renew it's dhcp address or something similar.. 


Apr 14 01:37:52 localhost kernel: airo: BAP error 4000 2
Apr 14 01:37:52 localhost kernel: Warning: kfree_skb passed an skb still on a
list (from c01219fa).
Apr 14 01:37:52 localhost kernel: ------------[ cut here ]------------
Apr 14 01:37:52 localhost kernel: kernel BUG at skbuff.c:315!
Apr 14 01:37:52 localhost kernel: invalid operand: 0000
Apr 14 01:37:52 localhost kernel: i810_audio ac97_codec soundcore radeon agpgart
speedstep i8k parport_pc lp parport iptable_filter ip_tables autofs airo_cs airo
ds yenta_socket pcmcia_core 3c
Apr 14 01:37:52 localhost kernel: CPU:    0
Apr 14 01:37:52 localhost kernel: EIP:    0060:[<c01f14d4>]    Not tainted
Apr 14 01:37:52 localhost kernel: EFLAGS: 00210282
Apr 14 01:37:52 localhost kernel:
Apr 14 01:37:52 localhost kernel: EIP is at __kfree_skb [kernel] 0x144 (2.4.20-8)
Apr 14 01:37:52 localhost kernel: eax: 00000045   ebx: f6e98a80   ecx: 00000001
  edx: c1ea4000
Apr 14 01:37:52 localhost kernel: esi: c1e17f90   edi: c1e16306   ebp: c1e16000
  esp: c1e17f78
Apr 14 01:37:52 localhost kernel: ds: 0068   es: 0068   ss: 0068
Apr 14 01:37:52 localhost kernel: Process keventd (pid: 2, stackpage=c1e17000)
Apr 14 01:37:52 localhost kernel: Stack: c0274fa0 c01219fa c1e16306 c1e17f90
c01219fa f6e98a80 f6e202e4 f6e202e4
Apr 14 01:37:52 localhost kernel:        00000001 c025dcbb c012b983 c030c4f0
c1e17fb0 00000000 00000001 00000000
Apr 14 01:37:52 localhost kernel:        c0370100 00010000 00000000 c012b870
00000000 c036945c 00000000 c1e16000
Apr 14 01:37:52 localhost kernel: Call Trace:   [<c01219fa>] __run_task_queue
[kernel] 0x5a (0xc1e17f7c))
Apr 14 01:37:52 localhost kernel: [<c01219fa>] __run_task_queue [kernel] 0x5a
(0xc1e17f88))
Apr 14 01:37:52 localhost kernel: [<c012b983>] context_thread [kernel] 0x113
(0xc1e17fa0))
Apr 14 01:37:52 localhost kernel: [<c012b870>] context_thread [kernel] 0x0
(0xc1e17fc4))
Apr 14 01:37:52 localhost kernel: [<c012b870>] context_thread [kernel] 0x0
(0xc1e17fe0))
Apr 14 01:37:52 localhost kernel: [<c010742d>] kernel_thread_helper [kernel] 0x5
(0xc1e17ff0))
Apr 14 01:37:52 localhost kernel:
Apr 14 01:37:52 localhost kernel:
Apr 14 01:37:52 localhost kernel: Code: 0f 0b 3b 01 93 3d 27 c0 8b 5c 24 14 e9
be fe ff ff 8d 74 26
Apr 14 01:37:52 localhost kernel:  <3>airo: BAP error 4000 2
Comment 2 Greg Bailey 2003-06-02 15:53:45 EDT
Me too, although it's only happened to me once so far

Compaq Armada M700 (Redhat 7.3)

Jun  1 17:11:12 rover kernel: airo: BAP error 4000 2
Jun  1 17:11:12 rover kernel: Warning: kfree_skb passed an skb still on a list
(from c89537cc).
Jun  1 17:11:12 rover kernel: ------------[ cut here ]------------
Jun  1 17:11:12 rover kernel: kernel BUG at skbuff.c:315!
Jun  1 17:11:12 rover kernel: invalid operand: 0000
Jun  1 17:11:12 rover kernel: ppp_deflate zlib_deflate ppp_async ppp_generic
slhc binfmt_misc airo_cs airo ds yenta_socket pcmcia_core eepro100 mii lt_serial
lt_modem ide-cd cdrom nls_iso8
Jun  1 17:11:12 rover kernel: CPU:    0
Jun  1 17:11:12 rover kernel: EIP:    0010:[<c01d191b>]    Tainted: P
Jun  1 17:11:12 rover kernel: EFLAGS: 00010292
Jun  1 17:11:12 rover kernel:
Jun  1 17:11:12 rover kernel: EIP is at __kfree_skb [kernel] 0x1b (2.4.20-13.7)
Jun  1 17:11:12 rover kernel: eax: 00000045   ebx: 00000246   ecx: c14c4000  
edx: 00000001
Jun  1 17:11:12 rover kernel: esi: 00000000   edi: c53310c8   ebp: c6dc0000  
esp: c1461f34
Jun  1 17:11:12 rover kernel: ds: 0018   es: 0018   ss: 0018
Jun  1 17:11:12 rover kernel: Process keventd (pid: 2, stackpage=c1461000)
Jun  1 17:11:12 rover kernel: Stack: c0248400 c89537cc c42b6e80 c89537cc
c42b6e80 c6dc01c4 00000000 c1460000
Jun  1 17:11:12 rover kernel:        c5353f00 c01158af c1461f88 c1461f78
c1461f78 c1460558 c1460000 c011c349
Jun  1 17:11:12 rover kernel:        c6dc0000 c6dc02e4 c6dc02e4 00000000
00000000 c0124061 c02de420 0000000a
Jun  1 17:11:12 rover kernel: Call Trace:   [<c89537cc>] airo_do_xmit [airo]
0x13c (0xc1461f38))
Jun  1 17:11:12 rover kernel: [<c89537cc>] airo_do_xmit [airo] 0x13c (0xc1461f40))
Jun  1 17:11:12 rover kernel: [<c01158af>] schedule [kernel] 0x2df (0xc1461f58))
Jun  1 17:11:12 rover kernel: [<c011c349>] __run_task_queue [kernel] 0x49
(0xc1461f70))
Jun  1 17:11:12 rover kernel: [<c0124061>] context_thread [kernel] 0x121
(0xc1461f88))
Jun  1 17:11:12 rover kernel: [<c0123f40>] context_thread [kernel] 0x0 (0xc1461fc8))
Jun  1 17:11:12 rover kernel: [<c0105000>] stext [kernel] 0x0 (0xc1461fe8))
Jun  1 17:11:12 rover kernel: [<c0107146>] arch_kernel_thread [kernel] 0x26
(0xc1461ff0))
Jun  1 17:11:12 rover kernel: [<c0123f40>] context_thread [kernel] 0x0 (0xc1461ff8))
Jun  1 17:11:12 rover kernel:
Jun  1 17:11:12 rover kernel:
Jun  1 17:11:12 rover kernel: Code: 0f 0b 3b 01 b6 ce 24 c0 58 5a 8b 54 24 08 8b
42 28 85 c0 74
Jun  1 17:11:12 rover kernel:  <3>airo: BAP error 4000 2
Jun  1 17:11:13 rover kernel: airo: BAP error 4000 2
Jun  1 17:11:13 rover last message repeated 3 times
Comment 3 Alan Cox 2003-06-08 16:24:57 EDT

*** This bug has been marked as a duplicate of 83363 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:52:38 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.