Bug 88677 - snmpd dead but subsys locked
Summary: snmpd dead but subsys locked
Status: CLOSED DUPLICATE of bug 82146
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: net-snmp (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i686 Linux
high
high
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-11 19:51 UTC by R. Scott Baer
Modified: 2015-03-05 01:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description R. Scott Baer 2003-04-11 19:51:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
can't do an snmpwalk on a redhat 9 box

Version-Release number of selected component (if applicable):
net-snmp-5.0.6-17

How reproducible:
Always

Steps to Reproduce:
1.Use any snmpwalk on localhost,or from a remote box.
2.Before the test I issued a /etc/init.d/snmpd restart
3.After the test I issued a /etc/init.d/snmpd status

    

Actual Results:  <126.4.200.57> #/etc/init.d/snmpd restart
Stopping snmpd:      [OK]
Starting snmpd:      [OK]
<126.4.200.57> # snmpwalk -v2c -c public localhost
Timeout: No Response from localhost
<126.4.200.57> # /etc/init.d/snmpd status
snmpd dead but subsys locked


Expected Results:  listing of all snmp variables

Additional info:

I can run this same command from this box, and walk other snmp devies fine.

Comment 1 R. Scott Baer 2003-04-26 13:58:47 UTC
Has anyone duplicated this ??
Or at least commented on it ??

Comment 2 Phil Knirsch 2003-05-14 14:52:34 UTC
It depends on your configuration. It is a long standing and know issue that if
have configured net-snmp to only display subtrees (not .1) then an snmpwalk may
timeout while the snmpd is still running and busy for about 30-40 seconds.

The only working solution is to export the whole .1 tree.

Your problem is most likely related to bug #82146, so i am marking it as a
duplicate.

Read ya, Phil

*** This bug has been marked as a duplicate of 82146 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:52:38 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.