Bug 886792 - RHEVM-CLI: auto complete suggests "from_event_id" while it shouldn't
RHEVM-CLI: auto complete suggests "from_event_id" while it shouldn't
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-cli (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity low
: ---
: 3.2.0
Assigned To: Michael Pasternak
Ilia Meerovich
infra
:
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-12-13 02:59 EST by Oded Ramraz
Modified: 2016-02-10 14:16 EST (History)
9 users (show)

See Also:
Fixed In Version: SF4
Doc Type: Bug Fix
Doc Text:
When using auto complete 'from_event_id' was being included in the results. This error was triggered when the 'list events' command was executed, subsequent auto completes would erroneously include 'from_event_id'. The code has been altered to exclude this happening.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-10 16:29:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Oded Ramraz 2012-12-13 02:59:15 EST
Description of problem:

auto complete suggests  "from_event_id" while it shouldn't: I don't see the meaning of from_event_id for list vms for example ( see Additional Information ) 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

[RHEVM shell (connected)]# list vms 
case_sensitive  from_event_id   kwargs          max             query           show-all        storagedomain   


[RHEVM shell (connected)]# list quotas 
case_sensitive  datacenter      from_event_id   kwargs          max             query           show-all      


[RHEVM shell (connected)]# list events --max 5

id         : 1534
description: User admin@internal logged in.

id         : 1533
description: User admin logged in.

id         : 1532
description: VM Windows started on Host blue-vdsb

id         : 1531
description: VM Windows was started by admin (Host: blue-vdsb).

id         : 1530
description: VM Windows was stopped ungracefully by admin (Host: blue-vdsb).

[RHEVM shell (connected)]# list vms --from_event_id  1535

[RHEVM shell (connected)]# list vms --from_event_id  1533
Comment 1 Michael Pasternak 2012-12-13 03:20:38 EST
Oded,

what sdk/cli version you're using? i can't reproduce this:

[oVirt shell (connected)]# list vms 
case_sensitive  kwargs          max             query           show-all        storagedomain
Comment 3 Oded Ramraz 2012-12-13 03:28:51 EST
I think i understand how to reproduce it :

[RHEVM shell (connected)]# list events --max 1

id         : 1561
description: User admin@internal logged in.

[RHEVM shell (connected)]# show event --id "1561"

id         : 1561
description: User admin@internal logged in.
code       : 30
severity   : normal
time       : 2012-12-13T10:27:27.985+02:00
user-id    : fdfc627c-d875-11e0-90f0-83df133b58cc

[RHEVM shell (connected)]# list vms 
case_sensitive  from_event_id   kwargs          max             query           show-all        storagedomain   
[RHEVM shell (connected)]# list vms
Comment 5 Michael Pasternak 2012-12-16 04:31:58 EST
(In reply to comment #3)
> I think i understand how to reproduce it :
> 
> [RHEVM shell (connected)]# list events --max 1
> 
> id         : 1561
> description: User admin@internal logged in.
> 
> [RHEVM shell (connected)]# show event --id "1561"
> 
> id         : 1561
> description: User admin@internal logged in.
> code       : 30
> severity   : normal
> time       : 2012-12-13T10:27:27.985+02:00
> user-id    : fdfc627c-d875-11e0-90f0-83df133b58cc
> 
> [RHEVM shell (connected)]# list vms 
> case_sensitive  from_event_id   kwargs          max             query       
> show-all        storagedomain   
> [RHEVM shell (connected)]# list vms

thanks, i was able reproducing it like this:

1)
[oVirt shell (connected)]# list events 
case_sensitive  from_event_id   kwargs          max             query           show-all        

2)
[oVirt shell (connected)]# list vms 
case_sensitive  from_event_id   kwargs          max             query           show-all        storagedomain  

i.e trigger is "list events"
Comment 6 Michael Pasternak 2012-12-16 05:01:51 EST
http://gerrit.ovirt.org/10102
Comment 7 Oded Ramraz 2013-02-06 05:16:38 EST
[RHEVM shell (connected)]# list events --max 1

id         : 12375
description: User admin@internal logged in.

[RHEVM shell (connected)]# show event --id "12374"

id         : 12374
description: User admin@internal logged in.
code       : 30
custom_id  : -1
flood_rate : 30
origin     : oVirt
severity   : normal
time       : 2013-02-06T12:14:58.356+02:00
user-id    : fdfc627c-d875-11e0-90f0-83df133b58cc

[RHEVM shell (connected)]# list vms 
case_sensitive  kwargs          max             query           show-all        storagedomain  


Verified sf5
Comment 8 errata-xmlrpc 2013-06-10 16:29:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0890.html

Note You need to log in before you can comment on or make changes to this bug.