Bug 886794 - REST-API : list files issues
REST-API : list files issues
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.2.0
Assigned To: Ravi Nori
Ilia Meerovich
infra
:
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-12-13 03:12 EST by Oded Ramraz
Modified: 2016-02-10 14:29 EST (History)
11 users (show)

See Also:
Fixed In Version: sf4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oded Ramraz 2012-12-13 03:12:42 EST
Description of problem:

I encountered few issues while using list files command 

1.list files --max parameter retrieve extra results ( see additional information )
2.not sure why id and name are equal for all entities . I think that it would be better if ID will be UUID or integer . 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

[RHEVM shell (connected)]# list files --storagedomain-identifier 7233a711-98e8-4c3c-bcfa-44c4bcc4f6c6 --max 3

id         : Windows2003-r2-x64-disc1.iso
name       : Windows2003-r2-x64-disc1.iso

id         : RHEL5.5-Server-20100201.0-x86_64-DVD.iso
name       : RHEL5.5-Server-20100201.0-x86_64-DVD.iso

id         : RHEV-toolsSetup_2.2_47513.iso
name       : RHEV-toolsSetup_2.2_47513.iso

id         : win2k3-32-with-virtio.vfd
name       : win2k3-32-with-virtio.vfd

id         : win2k8-32_with_virtio.vfd
name       : win2k8-32_with_virtio.vfd

id         : win7-32_with_virtio.vfd
name       : win7-32_with_virtio.vfd

[RHEVM shell (connected)]# list files --storagedomain-identifier 7233a711-98e8-4c3c-bcfa-44c4bcc4f6c6 --max 2

id         : fakeISO01.iso
name       : fakeISO01.iso

id         : RHEV-toolsSetup_2.3_327.iso
name       : RHEV-toolsSetup_2.3_327.iso

id         : win2k3-32-with-virtio.vfd
name       : win2k3-32-with-virtio.vfd

id         : win2k8-32_with_virtio.vfd
name       : win2k8-32_with_virtio.vfd
Comment 1 Michael Pasternak 2012-12-13 03:41:46 EST
(In reply to comment #0)
> Description of problem:
> 
> I encountered few issues while using list files command 
> 
> 1.list files --max parameter retrieve extra results ( see additional
> information )
> 2.not sure why id and name are equal for all entities . I think that it
> would be better if ID will be UUID or integer . 
> 

none of the mentioned above is related to cli,

1. --max can be an issue in api on this sub-collection (will be checked)
2. works fine with RESTful api where ID is opaque (but you can file RFE against 
   api making it UUID).
Comment 2 Ravi Nori 2012-12-13 07:57:28 EST
I am unable to reproduce the bug. Please try with the lastest cli code base and let me know if you can reproduce the bug.
Comment 3 Oded Ramraz 2012-12-13 08:03:02 EST
Do you have both ISO's and VFD's in your ISO domain ? 
It seems like it retrieve X VFD's and X ISO's when using max query 

(In reply to comment #2)
> I am unable to reproduce the bug. Please try with the lastest cli code base
> and let me know if you can reproduce the bug.
Comment 4 Ravi Nori 2012-12-13 09:02:23 EST
Yes I see the bug, this patch should fix the issue

http://gerrit.ovirt.org/#/c/10029/

change id : I7cf453d430f44dff8725ea11ecc0fa91d99844bc
Comment 6 Oded Ramraz 2013-02-06 05:03:45 EST
[RHEVM shell (connected)]# list files --storagedomain-identifier 7233a711-98e8-4c3c-bcfa-44c4bcc4f6c6 --max 3

id         : RHEV-toolsSetup_2.3_395.iso
name       : RHEV-toolsSetup_2.3_395.iso

id         : MUI_Windows_server_2003_r2_cd1.iso
name       : MUI_Windows_server_2003_r2_cd1.iso

id         : RHEV-toolsSetup_2.3_338.iso
name       : RHEV-toolsSetup_2.3_338.iso


Verified sf5
Comment 7 Itamar Heim 2013-06-11 04:20:54 EDT
3.2 has been released
Comment 8 Itamar Heim 2013-06-11 04:24:05 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.