This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 886831 - ISE and Tracebacks after Confirming Package Sync between 2 Channels
ISE and Tracebacks after Confirming Package Sync between 2 Channels
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: WebUI (Show other bugs)
1.8
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Lestach
Red Hat Satellite QA List
:
Depends On:
Blocks: space19
  Show dependency treegraph
 
Reported: 2012-12-13 04:47 EST by Stefan Kutzke
Modified: 2013-03-06 13:34 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-06 13:34:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stefan Kutzke 2012-12-13 04:47:41 EST
Description of problem:
Got an ISE and 2 tracebacks after merging packages.


Version-Release number of selected component (if applicable):
- CentOS 6.3 (x86_64)
- Spacewalk 1.8 with PostgreSQL (latest packages):
spacewalk-config-1.8.6-1.el6.noarch
spacewalk-java-1.8.181-1.el6.noarch
spacewalk-backend-xmlrpc-1.8.85-1.el6.noarch
spacewalk-backend-config-files-tool-1.8.85-1.el6.noarch
spacewalk-backend-applet-1.8.85-1.el6.noarch
spacewalk-admin-1.8.6-1.el6.noarch
spacewalk-setup-1.8.24-1.el6.noarch
spacewalk-html-1.8.49-1.el6.noarch
spacewalk-doc-indexes-1.1.1-1.el6.noarch
spacewalk-setup-jabberd-1.8.7-1.el6.noarch
spacewalk-java-config-1.8.181-1.el6.noarch
spacewalk-taskomatic-1.8.181-1.el6.noarch
spacewalk-backend-xml-export-libs-1.8.85-1.el6.noarch
spacewalk-backend-config-files-1.8.85-1.el6.noarch
spacewalk-base-1.8.49-1.el6.noarch
spacewalk-grail-1.8.49-1.el6.noarch
spacewalk-jpp-workaround-1.0.4-1.el6.noarch
spacewalk-schema-1.8.89-1.el6.noarch
spacewalk-search-1.8.6-1.el6.noarch
spacewalk-backend-sql-postgresql-1.8.85-1.el6.noarch
spacewalk-backend-sql-1.8.85-1.el6.noarch
spacewalk-java-lib-1.8.181-1.el6.noarch
spacewalk-backend-config-files-common-1.8.85-1.el6.noarch
spacewalk-backend-iss-export-1.8.85-1.el6.noarch
spacewalk-backend-iss-1.8.85-1.el6.noarch
spacewalk-pxt-1.8.49-1.el6.noarch
spacewalk-sniglets-1.8.49-1.el6.noarch
spacewalk-backend-libs-1.8.85-1.el6.noarch
spacewalk-monitoring-1.4.1-1.el6.noarch
spacewalk-backend-tools-1.8.85-1.el6.noarch
spacewalk-branding-1.8.7-1.el6.noarch
spacewalk-postgresql-1.8.6-1.el6.noarch
spacewalk-backend-1.8.85-1.el6.noarch
spacewalk-java-postgresql-1.8.181-1.el6.noarch
spacewalk-repo-1.8-4.el6.noarch
spacewalk-backend-server-1.8.85-1.el6.noarch
spacewalk-backend-app-1.8.85-1.el6.noarch
spacewalk-backend-package-push-server-1.8.85-1.el6.noarch
spacewalk-monitoring-selinux-1.8.4-1.el6.noarch
spacewalk-certs-tools-1.8.4-1.el6.noarch
spacewalk-selinux-1.8.2-1.el6.noarch
spacewalk-base-minimal-1.8.49-1.el6.noarch
spacewalk-slf4j-1.6.1-1.el6.noarch
spacewalk-common-1.8.6-1.el6.noarch
rhn-org-httpd-ssl-key-pair-spacewalk-1.0-1.noarch


How reproducible:

Steps to Reproduce:
1. Create a new Software Channel
2. Select: Manage Software Channels
3. Select Tab "Packages" and click "Compare Packages"
4. Select another existing Channel to compare to and click "Compare"
5. Click "Merge Differences"
6. Select: Make identical to ... and click "Preview Merge"
7. Click "Select All" and "Merge Packages"
8. Click "Confirm"
  
Actual results:
1. 500 Internal Server Error
2. Traceback 1:
The following exception occurred while executing this request:
 POST /network/software/channels/manage/packages/compare/sync_confirm.pxt HTTP/1.1 (from browser)
 /errors/500.pxt (from Apache)

Date:
  Thu Dec 13 10:36:07 2012

Headers:
  Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
  Accept-Encoding: gzip, deflate
  Accept-Language: de-de,de;q=0.8,en-us;q=0.5,en;q=0.3
  Connection: keep-alive
  Content-Length: 546
  Content-Type: application/x-www-form-urlencoded
  Cookie: pxt-session-cookie=71596xc1da5149853c3a6bba14e719526b3762
  Host: spacewalk.bm.loc
  Referer: https://spacewalk.bm.loc/network/software/channels/manage/packages/compare/sync_confirm.pxt?set_label=packages_for_merge&sync_type=full_sync&view_channel=channel_129&cid=119
  User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:16.0) Gecko/20100101 Firefox/16.0

Form variables:


User Information:
(not logged in)

Error notes:
  (none)

Initial Request:
  No

Error message:
  RHN::Exception: DBD::Pg::st execute failed: ERROR:  current transaction is aborted, commands ignored until end of transaction block
  RHN::DB /usr/share/perl5/vendor_perl/RHN/DB.pm 121 RHN::Exception::DB::throw
  RHN::DB::User /usr/share/perl5/vendor_perl/RHN/DB/User.pm 1444 RHN::DB::handle_error
  RHN::Access /usr/share/perl5/vendor_perl/RHN/Access.pm 71 RHN::DB::User::satellite_has_users
  PXT::ACL /usr/share/perl5/vendor_perl/PXT/ACL.pm 93 RHN::Access::need_first_user
  Sniglets::Navi::Node /usr/share/perl5/vendor_perl/Sniglets/Navi/Node.pm 195 PXT::ACL::eval_acl
  Sniglets::Navi /usr/share/perl5/vendor_perl/Sniglets/Navi.pm 202 Sniglets::Navi::Node::visible
  Sniglets::Navi /usr/share/perl5/vendor_perl/Sniglets/Navi.pm 168 Sniglets::Navi::render_nav
  Sniglets::Navi /usr/share/perl5/vendor_perl/Sniglets/Navi.pm 128 Sniglets::Navi::format_nav
  PXT::Parser /usr/share/perl5/vendor_perl/PXT/Parser.pm 141 Sniglets::Navi::navi_nav
  PXT::Parser /usr/share/perl5/vendor_perl/PXT/Parser.pm 72 PXT::Parser::expand_tag
  PXT::ApacheHandler /usr/share/perl5/vendor_perl/PXT/ApacheHandler.pm 489 PXT::Parser::expand_tags
  PXT::Request /usr/share/perl5/vendor_perl/PXT/Request.pm 548 PXT::ApacheHandler::pxt_parse_data
  Grail::Frame /usr/share/perl5/vendor_perl/Grail/Frame.pm 77 PXT::Request::include
  PXT::Parser /usr/share/perl5/vendor_perl/PXT/Parser.pm 160 Grail::Frame::canvas_template_handler
  PXT::Parser /usr/share/perl5/vendor_perl/PXT/Parser.pm 72 PXT::Parser::expand_tag
  PXT::ApacheHandler /usr/share/perl5/vendor_perl/PXT/ApacheHandler.pm 489 PXT::Parser::expand_tags
  PXT::ApacheHandler /usr/share/perl5/vendor_perl/PXT/ApacheHandler.pm 103 PXT::ApacheHandler::pxt_parse_data
  PXT::ApacheHandler /usr/share/perl5/vendor_perl/PXT/ApacheHandler.pm 103 (eval)
  main -e 0 PXT::ApacheHandler::handler
  main -e 0 (eval)

3. Traceback 2:
The following exception occurred while executing this request:
 POST /network/software/channels/manage/packages/compare/sync_confirm.pxt HTTP/1.1 (from browser)
 /network/software/channels/manage/packages/compare/sync_confirm.pxt (from Apache)

Date:
  Thu Dec 13 10:36:07 2012

Headers:
  Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
  Accept-Encoding: gzip, deflate
  Accept-Language: de-de,de;q=0.8,en-us;q=0.5,en;q=0.3
  Connection: keep-alive
  Content-Length: 546
  Content-Type: application/x-www-form-urlencoded
  Cookie: pxt-session-cookie=71596xc1da5149853c3a6bba14e719526b3762
  Host: spacewalk.bm.loc
  Referer: https://spacewalk.bm.loc/network/software/channels/manage/packages/compare/sync_confirm.pxt?set_label=packages_for_merge&sync_type=full_sync&view_channel=channel_129&cid=119
  User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:16.0) Gecko/20100101 Firefox/16.0

Form variables:
  alphabar_column => 
  cid => 119
  first_lower => 1
  first_upper => 100
  formvars => set_label
  formvars => set_label
  formvars => set_label
  formvars => set_label
  formvars => set_label
  last_lower => 8001
  last_upper => 8082
  list_action_label_sync_packages_to_channel => Confirm
  list_action_url_sync_packages_to_channel => /rhn/channels/manage/ChannelPackages.do
  list_mode => sync_confirm_packages_in_set
  lower => 1
  next_lower => 101
  next_upper => 200
  prev_lower => 1
  prev_upper => 100
  pxt:trap => rhn:package_list_cb
  set_label => packages_for_merge
  sync_type => full_sync
  upper => 100
  view_channel => channel_129

User Information:
  User skutzke (id 2, org_id 1)

Error notes:
  (none)

Initial Request:
  Yes

Error message:
  RHN::Exception: DBD::Pg::st execute failed: ERROR:  column "sysdate" does not exist
LINE 5: ...rl-web::remove_channel_packages', NULL, 'N', 'N', sysdate, s...
                                                             ^
  RHN::DB /usr/share/perl5/vendor_perl/RHN/DB.pm 121 RHN::Exception::DB::throw
  RHN::DB::st /usr/share/perl5/vendor_perl/RHN/DB.pm 455 RHN::DB::handle_error
  RHN::DB::ChannelEditor /usr/share/perl5/vendor_perl/RHN/DB/ChannelEditor.pm 289 RHN::DB::st::execute_h
  Sniglets::ListView::PackageList /usr/share/perl5/vendor_perl/Sniglets/ListView/PackageList.pm 1918 RHN::DB::ChannelEditor::remove_channel_packages
  Sniglets::ListView::PackageList /usr/share/perl5/vendor_perl/Sniglets/ListView/PackageList.pm 274 Sniglets::ListView::PackageList::sync_packages_to_channel_cb
  Sniglets::ListView::List /usr/share/perl5/vendor_perl/Sniglets/ListView/List.pm 374 Sniglets::ListView::PackageList::default_callback
  Sniglets::Lists /usr/share/perl5/vendor_perl/Sniglets/Lists.pm 135 Sniglets::ListView::List::callback
  PXT::ApacheHandler /usr/share/perl5/vendor_perl/PXT/ApacheHandler.pm 478 Sniglets::Lists::listview_cb
  PXT::ApacheHandler /usr/share/perl5/vendor_perl/PXT/ApacheHandler.pm 103 PXT::ApacheHandler::pxt_parse_data
  PXT::ApacheHandler /usr/share/perl5/vendor_perl/PXT/ApacheHandler.pm 103 (eval)
  main -e 0 PXT::ApacheHandler::handler
  main -e 0 (eval)


Expected results:
Summary Page with Packages added to new channel

Additional info:
Even so packages were added to new channel
Comment 1 Stefan Kutzke 2013-01-21 06:21:06 EST
Maybe related to: https://www.redhat.com/archives/spacewalk-list/2012-December/msg00038.html
Comment 2 Tomas Lestach 2013-01-24 04:54:11 EST
spacewalk.git: 4abccd4fb53017e4822ffa6e4e7d45b2a40598ae
Comment 3 Stephen Herr 2013-03-01 12:07:33 EST
Marking bug as ON_QA since tonight's build of Spacewalk nightly is a release candidate for Spacewalk 1.9.
Comment 4 Stephen Herr 2013-03-06 13:34:58 EST
Spacewalk 1.9 has been released.

https://fedorahosted.org/spacewalk/wiki/ReleaseNotes19

Note You need to log in before you can comment on or make changes to this bug.