This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 886838 - libdb license problem (Artistic License)
libdb license problem (Artistic License)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libdb (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Staněk
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-13 05:14 EST by mejiko
Modified: 2013-05-28 11:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-28 11:29:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Savannah 29840 None None None Never

  None (edit)
Description mejiko 2012-12-13 05:14:29 EST
Hello.

libdb package included non free file.

source: libdb-5.2.36-5.fc17.src.rpm
file: src/crypto/mersenne/mt19937db.c
license: Artistic License (license version is not elected.)

If apply Artistic License version 2.0, this is no problem. (Fedora accepted license)

If apply Artistic License version 1.0, this is license problem (Fedora not accept license, and not GPL compatible) 

Question: Which is apply license version ? I don't know.


Suggests:

1. remove this file and rebuild.

2. replace to free software (Accepted Fedora) file.

3. remove fedora repos.


Thanks.



Referense:

https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing#Bad_Licenses

https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing#Good_Licenses

https://www.gnu.org/licenses/license-list.ja.html#NonFreeSoftwareLicense

https://lists.nongnu.org/archive/html/gnu-linux-libre/2010-05/msg00000.html

https://lists.nongnu.org/archive/html/gnu-linux-libre/2010-05/txtarkT73E26o.txt
Comment 1 Jindrich Novy 2012-12-13 11:37:45 EST
Tom, since IANAL, could you please check this?
Comment 2 Tom "spot" Callaway 2012-12-13 12:31:24 EST
The original file that this is based off of has quite a storied history.

https://lists.nongnu.org/archive/html/gnu-linux-libre/2010-05/msg00000.html includes correspondence from the copyright holders giving permission for use under the GPL. But even that is unnecessary, since that code has previously been licensed under the LGPL:

http://web.archive.org/web/20010806225716/http://www.math.keio.ac.jp/matumoto/mt19937int.c

I would think that the simplest solution for now would be to use this code under the terms of the LGPLv2+, and just append that License to the spec file tag.

Jindrich, you probably want to let the libdb upstream know about this, they may prefer it to be under BSD instead, and I would imagine that Makoto Matsumoto and Takuji Nishimura would be willing to grant permission for that code to be used under BSD license terms.

But this is not a blocker for Fedora as is.

Just as a reminder: Legal issues like this should be blocked against "FE-Legal" so that they land in my INBOX for review. :)
Comment 3 mejiko 2012-12-14 05:41:39 EST
Blocked FE-legal, This is license problem.
Comment 4 Tom "spot" Callaway 2012-12-14 10:46:01 EST
I'm sorry, I thought I made that aspect clear, this is not a current license problem. That last piece of information was just a reminder of how to get issues like this to my attention.

Fedora is fine to retain this file as is, we just need to include "LGPLv2+" in the package License tag. Jindrich should reach out to the libdb upstream to inform them that they either need to change the license in the file to reflect the LGPLv2+ license option or reach out to Makoto Matsumoto and Takuji Nishimura and ask them to grant permission for that original mt19937int.c code to be used under BSD license terms.

Lifting FE-Legal.
Comment 5 mejiko 2013-02-27 05:17:35 EST
This bug is affected Fedora 18.

How it this bug current status ? (responce from upstream author, "mt19937db.c" license status, etc...)

Is this bug is resolved ?

Thanks.
Comment 6 mejiko 2013-03-07 06:59:21 EST
Why change bug stete is "NEW" to "MODIFIED" ?
I see libdb.git (fedora), Its not change. 

Source URI:

http://pkgs.fedoraproject.org/cgit/libdb.git/tree/?h=f18

thanks.


Reference:

https://fedoraproject.org/wiki/BugZappers/BugStatusWorkFlow#MODIFIED
Comment 7 Jindrich Novy 2013-03-07 07:59:09 EST
The license field in f18 and rawhide now says:

License: BSD and LGPLv2+

Please verify if it's OK. Still no reply from Oracle on that.
Comment 8 Fedora Admin XMLRPC Client 2013-03-12 09:45:28 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 9 Fedora Admin XMLRPC Client 2013-03-20 05:17:51 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 11 Tom "spot" Callaway 2013-05-17 13:34:16 EDT
This landed in 5.3.21-10.fc20.
Comment 12 mejiko 2013-05-26 05:42:46 EDT
Re-open this bug. and Im sorry.


[Problem 1]


I checked fedora "libdb.git" version "007-mt19937db.c_license.patch" and trisquel's original patch, diff path name is changed (fedora version).

but "clearly modified statement" (changelog, E.g changing date, etc...) is not find, and not written. Im confuse original patch.

and I *think* that this patch license is GPLv3. (I see top directory, and I see "COPYING".) 

Is this is correct ?

URI: http://devel.trisquel.info/gitweb/?p=package-helpers.git;a=tree


If this patch license is GPLv3, fedora version patch is GPLv3 paragraph 4 and 5 not compliant. Its non-free and license problem. (I *think*) 

I recommend that compliance GPL, written change log, and include GPL license text. (GPLv3 paragraph 4 and 5-a ).

If not this license is GPLv3, What is this patch licensed under ?


[Problem 2]

Patched mt19937db.c license is LGPL, but license text is missing. I suggest that include license text.


Thanks.
Comment 13 Tom "spot" Callaway 2013-05-28 11:29:13 EDT
I do not believe that patch is GPLv3+, as Trisquel has no copyright over that change. The patch is simply applying the license change from the mt19937db upstream version. It would be very very difficult to argue that a unified diff file (and not the changes represented inside of it) is a copyrightable work.

The missing license text is a minor issue however, and I have remedied it in rawhide.

Note You need to log in before you can comment on or make changes to this bug.