This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 886843 - New changes in Bugzilla 4.4 RPC API
New changes in Bugzilla 4.4 RPC API
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-bugzilla (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
: 608050 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-13 05:37 EST by Tomas Tomecek
Modified: 2013-03-22 17:17 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-22 17:17:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tomas Tomecek 2012-12-13 05:37:55 EST
Description of problem:
There was deployed new version of bugzilla for beta testing with modified RPC API. RPC calls in package should be updated.

http://post-office.corp.redhat.com/archives/core-services-brno/2012-December/msg00031.html
http://post-office.corp.redhat.com/archives/core-services-brno/2012-December/msg00030.html

Version-Release number of selected component (if applicable):
Version     : 0.7.0
Release     : 1.fc17

Steps to Reproduce:
1. python -c "import bugzilla ; bugzilla.Bugzilla(url='https://bzweb01-devel.app.eng.rdu.redhat.com/xmlrpc.cgi')"
  
Actual results:
Traceback (most recent call last):
  File "bugzilla_test.py", line 23, in <module>
    main()
  File "bugzilla_test.py", line 18, in main
    bz = bugzilla.Bugzilla(url=BZ_URL)
  File "/usr/lib/python2.7/site-packages/bugzilla/__init__.py", line 75, in __init__
    c = getBugzillaClassForURL(kwargs['url'])
  File "/usr/lib/python2.7/site-packages/bugzilla/__init__.py", line 35, in getBugzillaClassForURL
    prodinfo = s.bugzilla.getProdInfo()
  File "/usr/lib64/python2.7/xmlrpclib.py", line 1224, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib64/python2.7/xmlrpclib.py", line 1578, in __request
    verbose=self.__verbose
  File "/usr/lib64/python2.7/xmlrpclib.py", line 1264, in request
    return self.single_request(host, handler, request_body, verbose)
  File "/usr/lib64/python2.7/xmlrpclib.py", line 1312, in single_request
    response.msg,
xmlrpclib.ProtocolError: <ProtocolError for bzweb01-devel.app.eng.rdu.redhat.com/xmlrpc.cgi: 410 This RPC call has been replaced by Product.get. See https://bugzilla.redhat.com/show_bug.cgi?id=822007>
Comment 1 Cole Robinson 2012-12-28 16:02:59 EST
Yep, I've been working on this upstream. Much of the work is already done, and there will be a new version out in time for the RHBZ upgrade.
Comment 2 Cole Robinson 2012-12-28 16:16:13 EST
*** Bug 608050 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2013-02-16 10:21:53 EST
python-bugzilla-0.8.0-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/python-bugzilla-0.8.0-1.fc17
Comment 4 Fedora Update System 2013-03-04 17:18:45 EST
python-bugzilla-0.8.0-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/python-bugzilla-0.8.0-2.fc17
Comment 5 Fedora Update System 2013-03-05 18:20:57 EST
Package python-bugzilla-0.8.0-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-bugzilla-0.8.0-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-3435/python-bugzilla-0.8.0-2.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-03-22 17:17:15 EDT
python-bugzilla-0.8.0-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.