Bug 886887 - Firstboot : Upon entering an invalid activation key,throws an alert messsage but takes you to a system registration screen
Firstboot : Upon entering an invalid activation key,throws an alert messsage ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Alex Wood
IDM QE LIST
: QA-Closed
Depends On:
Blocks: 771481 895654
  Show dependency treegraph
 
Reported: 2012-12-13 08:38 EST by Shwetha Kallesh
Modified: 2013-02-21 04:03 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 04:03:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Hangs in the system registration screen (136.26 KB, image/png)
2012-12-13 08:38 EST, Shwetha Kallesh
no flags Details

  None (edit)
Description Shwetha Kallesh 2012-12-13 08:38:41 EST
Created attachment 662968 [details]
Hangs in the system registration screen

Description of problem:
Firstboot : Upon entering an invalid activation key,throws an alert messsage but  takes you a system registration screen and goes no where. Instead should take you to previous screen and let the user enter values again

Version-Release number of selected component (if applicable):

[root@rhel-64-server ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.7.21-1
subscription-manager: 1.1.14-1.el6
python-rhsm: 1.1.7-1.el6


How reproducible:


Steps to Reproduce:
1.firstboot -r

[root@rhel-64-server ~]# firstboot -r
firstboot DEBUG: Loading current RPM profile.
firstboot INFO: Using certificate authentication: key = /etc/pki/consumer/key.pem, cert = /etc/pki/consumer/cert.pem, ca = /etc/rhsm/ca/, insecure = False
firstboot INFO: Connection Built: host: 10.70.35.126, port: 8443, handler: /candlepin
firstboot DEBUG: ContectConnection
firstboot DEBUG: Loading consumer info from identity certificates.
firstboot DEBUG: Successfully loaded module rhsm_login, adding
firstboot DEBUG: Successfully loaded module rhn_create_profile_gui, adding
firstboot DEBUG: Successfully loaded module rhn_review_gui, adding
firstboot DEBUG: Successfully loaded module rhn_finish_gui, adding
firstboot DEBUG: Successfully loaded module rhn_provide_certificate_gui, adding
firstboot DEBUG: Successfully loaded module rhn_choose_channel, adding
firstboot DEBUG: Successfully loaded module rhn_login_gui, adding
Loading /lib/kbd/keymaps/i386/qwerty/us.map.gz
firstboot INFO: Using certificate authentication: key = /etc/pki/consumer/key.pem, cert = /etc/pki/consumer/cert.pem, ca = /etc/rhsm/ca/, insecure = False
firstboot INFO: Connection Built: host: 10.70.35.126, port: 8443, handler: /candlepin
firstboot INFO: Using no auth
firstboot INFO: Connection Built: host: 10.70.35.126, port: 8443, handler: /candlepin
firstboot DEBUG: Loading CA PEM certificates from: /etc/rhsm/ca/
firstboot DEBUG: Loading CA certificate: '/etc/rhsm/ca/candlepin-stage.pem'
firstboot DEBUG: Loading CA certificate: '/etc/rhsm/ca/10.pem'
firstboot DEBUG: Loading CA certificate: '/etc/rhsm/ca/redhat-uep.pem'
firstboot DEBUG: Loading CA certificate: '/etc/rhsm/ca/candlepin-ca.pem'
firstboot DEBUG: Making request: GET /candlepin/status/
firstboot DEBUG: Response status: 200
firstboot INFO: Writing server data to rhsm.conf
firstboot INFO: Using certificate authentication: key = /etc/pki/consumer/key.pem, cert = /etc/pki/consumer/cert.pem, ca = /etc/rhsm/ca/, insecure = False
firstboot INFO: Connection Built: host: 10.70.35.126, port: 8443, handler: /candlepin
firstboot DEBUG: ContectConnection
firstboot INFO: Using certificate authentication: key = /etc/pki/consumer/key.pem, cert = /etc/pki/consumer/cert.pem, ca = /etc/rhsm/ca/, insecure = False
firstboot INFO: Connection Built: host: 10.70.35.126, port: 8443, handler: /candlepin
firstboot INFO: Using no auth
firstboot INFO: Connection Built: host: 10.70.35.126, port: 8443, handler: /candlepin
firstboot INFO: Registering to owner: admin environment: None
firstboot ERROR: signal only works in main thread
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/hwprobe.py", line 410, in getVirtInfo
    host_type = self._get_output('virt-what')
  File "/usr/share/rhsm/subscription_manager/hwprobe.py", line 439, in _get_output
    signal.signal(signal.SIGPIPE, signal.SIG_DFL)
ValueError: signal only works in main thread
firstboot WARNING: Error finding UUID: 'virt.host_type'
firstboot DEBUG: Sorting product and entitlement cert status for: 2012-12-13 13:26:26.206004+00:00
firstboot DEBUG: Installed product IDs: ['37060', '37065', '37069', '37068', '37080', '27060', '69', '37067', '88888', '37070', '37062']
firstboot DEBUG: valid entitled products: []
firstboot DEBUG: expired entitled products: []
firstboot DEBUG: partially entitled products: []
firstboot DEBUG: unentitled products: ['88888', '27060', '37069', '37068', '37080', '37065', '69', '37067', '37060', '37070', '37062']
firstboot DEBUG: future products: []
firstboot DEBUG: partial stacks: []
firstboot DEBUG: valid stacks: []
firstboot DEBUG: Loading CA PEM certificates from: /etc/rhsm/ca/
firstboot DEBUG: Loading CA certificate: '/etc/rhsm/ca/candlepin-stage.pem'
firstboot DEBUG: Loading CA certificate: '/etc/rhsm/ca/10.pem'
firstboot DEBUG: Loading CA certificate: '/etc/rhsm/ca/redhat-uep.pem'
firstboot DEBUG: Loading CA certificate: '/etc/rhsm/ca/candlepin-ca.pem'
firstboot DEBUG: Making request: POST /candlepin/consumers?owner=admin&activation_keys=shwetha_test
firstboot DEBUG: Response status: 404
firstboot ERROR: Activation key 'shwetha_test' not found for organization 'admin'.
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/firstboot/rhsm_login.py", line 97, in _on_registration_finished_cb
    raise error
RestlibException: Activation key 'shwetha_test' not found for organization 'admin'.

Actual results:


Expected results:


Additional info:
Comment 2 RHEL Product and Program Management 2012-12-17 01:50:21 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 Alex Wood 2012-12-18 11:26:18 EST
commit 10e6e4a41e55fdc9d717cbc47d208a3c80bf3718
Author: Alex Wood <awood@redhat.com>
Date:   Tue Dec 18 10:17:20 2012 -0500

    886887: Take the user back to the activation key page if he enters an invalid key.
Comment 5 spandey 2013-01-02 02:15:10 EST
Verified using following subscription-manager rpm 

subscription-manager-migration-1.1.18-1.el6.x86_64
subscription-manager-migration-data-1.12.2.6-1.el6.noarch
subscription-manager-gui-1.1.18-1.el6.x86_64
subscription-manager-1.1.18-1.el6.x86_64
subscription-manager-firstboot-1.1.18-1.el6.x86_64


Working fine resolving defect as verified.
Comment 7 errata-xmlrpc 2013-02-21 04:03:47 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.