Bug 886922 - Wacom: Allow Multiple mode-switch Buttons to Select a Given Mode
Summary: Wacom: Allow Multiple mode-switch Buttons to Select a Given Mode
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-settings-daemon
Version: 6.4
Hardware: All
OS: Linux
medium
high
Target Milestone: rc
: 6.4
Assignee: Olivier Fourdan
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 888457
TreeView+ depends on / blocked
 
Reported: 2012-12-13 15:37 UTC by Michael Boisvert
Modified: 2013-03-21 09:38 UTC (History)
4 users (show)

Fixed In Version: gnome-settings-daemon-2.28.2-30.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 08:24:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 690157 None None None Never
Red Hat Product Errata RHBA-2013:0312 normal SHIPPED_LIVE gnome-settings-daemon bug fix and enhancement update 2013-02-20 20:35:14 UTC

Description Michael Boisvert 2012-12-13 15:37:06 UTC
Description of problem:

The Cintiq 24HD has a unique LED/mode switch feature than the other tablets.

There are three modes per side, but there are also 3 different buttons to
select modes. So you can go from mode 1 to mode 3 without cycling through mode
2, you just hit the individual button.

Currently, when you hit any of the mode switch buttons it just cycles through
them like the other tablets do.

How reproducible:
Always.

Steps to Reproduce:
1. Plug in 24HD
2. Press any mode button twice.
  
Actual results:
The mode switches while you select only one button.

Expected results:
The mode should be set by the individual buttons.

Comment 6 RHEL Program Management 2012-12-14 08:01:56 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.

Comment 10 Michael Boisvert 2013-01-10 19:20:04 UTC
This bug has been fixed in: gnome-settings-daemon-2.28.2-30.el6.

Verified.

Comment 12 errata-xmlrpc 2013-02-21 08:24:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0312.html


Note You need to log in before you can comment on or make changes to this bug.