Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 886930 - [Install the Mod_jk Module Into Apache HTTPD or Enterprise Web Server HTTPD]:
Summary: [Install the Mod_jk Module Into Apache HTTPD or Enterprise Web Server HTTPD]:
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: EAP 6.1.0
Assignee: Vikram Goyal
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-13 15:52 UTC by Jan Stefl
Modified: 2014-08-14 15:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Instance Name: Not Defined Build: CSProcessor Builder Version 1.7 Build Name: 8740, Administration and Configuration Guide-6-2 Build Date: 11-12-2012 17:04:01
Last Closed: 2013-05-24 00:28:36 UTC
Type: Bug


Attachments (Terms of Use)

Description Jan Stefl 2012-12-13 15:52:01 UTC
http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6/html/Administration_and_Configuration_Guide/Install_the_Mod_jk_Module_Into_Apache_HTTPD_or_Enterprise_Web_Server_HTTPD1.html

13.4.3. Install the Mod_jk Module Into Apache HTTPD or Enterprise Web Server HTTPD
There is mention only about RHEL. But we deliver natives (with mod_jk) for RHEL, Solaris, Windows.

---------------------------------------------------------------------------------

1. Determine your HTTPD configuration location.
"on whether you are using Red Hat Enterprise Linux's Apache HTTPD or the HTTPD available in JBoss Enterprise Web Platform."
->
"on whether you are using Red Hat Enterprise Linux's Apache HTTPD or the HTTPD available in JBoss Enterprise Web Server."

--------------------------------------------------------------------------------
Remove trailing "/", and add variant for Solaris and Windows.

1. Determine your HTTPD configuration location.
Apache HTTPD - /etc/httpd/
JBoss Enterprise Web Server HTTPD on RHEL - EWS_HOME/httpd
JBoss Enterprise Web Server HTTPD on Solaris - EWS_HOME/etc/httpd
JBoss Enterprise Web Server HTTPD on Windows - EWS_HOME/etc/httpd

--------------------------------------------------------------------------------

2. Configure the mod_jk module.
 - remove whole point a), if we add configuration into con.d, will be loaded automatically
 - "Create a new file called HTTPD_HOME/etc/httpd/conf/mod-jk.conf and add the following to it
   -> 
   "Create a new file called HTTPD_HOME/conf.d/mod-jk.conf and add the following to it

--------------------------------------------------------------------------------
Copy the mod_jk.so file to the HTTPD's modules directory
"Extract the Native Components ZIP package. Locate the mod_jk.so file in either the native/lib/httpd/modules/ or native/lib64/httpd/modules/ directory"
->
"Extract the Native Web Server Connectors ZIP package. Locate the mod_jk.so file in either the jboss-eap-6.0/modules/native/lib/httpd/modules/ or jboss-eap-6.0/modules/native/lib64/httpd/modules/ directory"

--------------------------------------------------------------------------------
B. JBoss Enterprise Web Server HTTPD
Add restart for Solaris
 - /opt/jboss-ews-2.0/sbin/apachectl restart

--------------------------------------------------------------------------------
I would add info about, that HTTPD from EWS is part of EAP distribution. I recommend add this info somewhere on top of the page (or even maybe on intro page - http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6/html/Administration_and_Configuration_Guide/sect-Apache_mod_jk.html).

Comment 1 Vikram Goyal 2013-03-06 04:17:36 UTC
I have made all of the requested changes. When the docs are built next, these changes can be seen here [1].

Moving this to MODIFIED.

[1] http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6/html/Administration_and_Configuration_Guide/Install_the_Mod_jk_Module_Into_Apache_HTTPD_or_Enterprise_Web_Server_HTTPD1.html

Comment 3 Jan Stefl 2013-03-11 08:52:08 UTC
If you are using Apache HTTPD, download the JBoss Enterprise Application Platform Native Components package for Red Hat Enterprise Linux from the Red Hat Customer Service Portal...
->
If you are using Apache HTTPD, download the JBoss Enterprise Application Platform Native Components package for your platform from the Red Hat Customer Service Portal...

----------------------------------------------------------------------------------------------

Remove formatting for word "file" in
Procedure 13.10. Task
 c. Copy the mod_jk.so file to the HTTPD's modules directory
  Extract the Native Web Server Connectors ZIP package. Locate the mod_jk.so {here}file{here} in ...


Verified with Revision 0.3-9, Thu Mar 07 2013

Comment 4 Vikram Goyal 2013-03-12 00:28:02 UTC
1. Removed the formatting around the word <file> in procedure 13.10 Task (c).
2. Fixed the language around "package for Red Hat Enterprise Linux" to "package for your platform".

Changes can be seen here [1] when the docs are built.

Moving this to MODIFIED.

[1] http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6-Beta/html/Administration_and_Configuration_Guide/Install_the_Mod_jk_Module_Into_Apache_HTTPD_or_Enterprise_Web_Server_HTTPD1.html

Comment 6 Jan Stefl 2013-03-19 11:53:42 UTC
Verified with Revision 0.3-12, Tue Mar 19 2013 - OK

Comment 7 Jan Stefl 2013-04-08 11:21:12 UTC
I have to reopen because there are regressions in version Revision 0.3-9.


Note You need to log in before you can comment on or make changes to this bug.