This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 886936 - Allow connection to the guest with non-responsive agent
Allow connection to the guest with non-responsive agent
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-userportal (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.1.3
Assigned To: Arik
Jiri Belka
virt
: ZStream
Depends On: 871083
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-13 10:58 EST by Idith Tal-Kohen
Modified: 2013-11-27 18:56 EST (History)
13 users (show)

See Also:
Fixed In Version: si27
Doc Type: Bug Fix
Doc Text:
Virtual machine connection options in the event of a non-responsive rhev-agent have changed. Previously the virtual machine showed an error and canceled the SPICE connection. Now, a confirmation dialog box appears, warning the user that the virtual machine will have reduced capabilities because the agent is non-responsive. The user may select to run the virtual machine anyway, or cancel. If the user continues, the SPICE console will be opened without SSO.
Story Points: ---
Clone Of: 871083
Environment:
Last Closed: 2013-03-12 10:26:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Idith Tal-Kohen 2012-12-13 10:58:59 EST
+++ This bug was initially created as a clone of Bug #871083 +++

Description of problem:
Allow connection to the guest with non-responsive agent.

The current behaviour is a workaround for spicec limitation that when agent-related feature was requested from it, it stalled until it established communication with agent. Spice-gtk-based clients are more fault-tolerant in this respect so this hard limitation of User Portal could safely be turned to soft one ("Agent is not responsive. Some features may not work. [cancel] [connect anyway]").


Version-Release number of selected component (if applicable):
si19.1 / 3.1.0-18

How reproducible:
always

Steps to Reproduce:
1. have a Windows VM with tools (mainly virtio-serial, rhev-agent and spice-vdagent running)
2. stop rhev-agent service
3. wait a while
4. try to connect to the VM again
  
Actual results:
you get this message:
Error while executing action VmLogon: Guest agent non-responsive
[close]

Expected results:
you get either dismissable warning (as outlined above; preferable solution) or no warning at all.

Additional info:

--- Additional comment from Arik on 2012-12-10 07:34:54 EST ---

Created attachment 660798 [details]
warning dialog on spice connection to guest with non responsive agent

--- Additional comment from Arik on 2012-12-10 08:00:36 EST ---

Simon - is the dialog in the attached picture seems ok? (if the user press cancel, the spice console connection is aborted, and if the user press ok the spice console is opened without logon)

--- Additional comment from Arik on 2012-12-11 11:08:43 EST ---

Created attachment 661532 [details]
Updated screenshot for the proposed dialog

--- Additional comment from Simon Grinberg on 2012-12-12 12:41:29 EST ---

(In reply to comment #2)
> Simon - is the dialog in the attached picture seems ok? (if the user press
> cancel, the spice console connection is aborted, and if the user press ok
> the spice console is opened without logon)

What happens if the tools are not installed in the first place? does the pop-up shows or do we connect anyhow? If it is the same then please change the first line.

Could not connect to the agent on the guest, it may be unresponsive or not installed.  

You can drop the third line, it's clear that the action is proceed or abort. 


We also need the option ignore that message for good, but this is part of the persistent session issues or the VM configuration.

--- Additional comment from Arik on 2012-12-13 10:18:10 EST ---

http://gerrit.ovirt.org/#/c/10030/
Comment 6 Jiri Belka 2013-02-20 07:55:04 EST
ok, si27.1.
Comment 8 errata-xmlrpc 2013-03-12 10:26:33 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0557.html

Note You need to log in before you can comment on or make changes to this bug.