Bug 886941 - RHEVM-CLI: missing acknowledgement for remove commands
RHEVM-CLI: missing acknowledgement for remove commands
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-cli (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.2.0
Assigned To: Michael Pasternak
Barak Dagan
infra
:
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-12-13 11:05 EST by Barak Dagan
Modified: 2016-02-10 14:29 EST (History)
10 users (show)

See Also:
Fixed In Version: SF4
Doc Type: Bug Fix
Doc Text:
By default the 'remove' command never printed an acknowledgement to the screen if the operation was successful. Only unsuccessful attempts were acknowledged. Now when 'remove' operates successfully the word 'Accepted' is printed to the screen.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-10 16:29:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Barak Dagan 2012-12-13 11:05:27 EST
Description of problem:
missing acknowledge for success operations:

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
success:
[RHEVM shell (connected)]# remove cluster barak
[RHEVM shell (connected)]# 


Failue:
[RHEVM shell (connected)]# remove cluster sdfhsdkfhs

error: cluster "sdfhsdkfhs" does not exist.

Expected results:
"cluster "barak" is removed" or "remove cluster: complete" - like start vm

Additional info:
Comment 1 Michael Pasternak 2012-12-13 11:21:55 EST
by-design, if command not failed it 'accepted' 
(note rest-api does not assure delete completion, it's only accepts request)
Comment 2 Michael Pasternak 2012-12-13 11:25:50 EST
i'll issue 'ACCEPTED' output on successful (api-wise) request
Comment 3 Michael Pasternak 2012-12-13 12:06:53 EST
http://gerrit.ovirt.org/10039
Comment 4 Oded Ramraz 2013-01-24 09:41:46 EST
[RHEVM shell (connected)]# remove cluster test2

accepted.

Verified sf4
Comment 5 errata-xmlrpc 2013-06-10 16:29:17 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0890.html

Note You need to log in before you can comment on or make changes to this bug.